Indicator Lens - Triumph Forum: Triumph Rat Motorcycle Forums
Water Cooled Twins Technical Talk Technical Talk for water cooled Triumph Twins.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-03-2019, 03:17 PM Thread Starter
Production 125
Main Motorcycle: Triumph T120 1200
New Member
 
Join Date: Mar 2017
Location: Selby UK
Posts: 10
Other Motorcycle: T140V in bits
Unhappy Indicator Lens

Has anybody had their indicator lens fall out of their bodies my rear indicator lens just fell out first the right one then a week later the left one.
Bogga is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-03-2019, 03:21 PM
World SuperBike
Main Motorcycle: 2013 Speed Triple
Senior Member
 
Cburt's Avatar
 
Join Date: May 2007
Location: Kansas City
Posts: 2,385
Quote:
Originally Posted by Bogga View Post
Has anybody had their indicator lens fall out of their bodies my rear indicator lens just fell out first the right one then a week later the left one.
Never heard or seen that happen. Ever!
Cburt is offline  
post #3 of 5 (permalink) Old 06-04-2019, 12:55 AM
Site Supporter
Formula Extreme
Main Motorcycle: 2017 Triumph T120
Lifetime Premium
 
Pudge's Avatar
 
Join Date: Aug 2016
Location: Atlanta, GA
Posts: 742
Quote:
Originally Posted by Bogga View Post
Has anybody had their indicator lens fall out of their bodies my rear indicator lens just fell out first the right one then a week later the left one.

You're not alone. See post # 20.


https://www.triumphrat.net/water-coo...fitting-2.html

Clearview windshield, Triumph Cruise Control Kit DRL Type 2, Pazzo levers, JW Speaker Evo 2 LED headlamp, Booster Plug, Triumph LED indicators, 4 bar tank badges, chrome throttle body, clutch and inspection covers.
Pudge is offline  
 
post #4 of 5 (permalink) Old 06-05-2019, 04:12 PM
Grand Prix 125
Main Motorcycle: 2017 Street Cup
Member
 
Streetiger's Avatar
 
Join Date: Dec 2018
Location: Central CT
Posts: 34
Other Motorcycle: 1969 Tiger
Garage
I could definitely see it happening. When I first read about this - the problem seemed to be how hard it was to get the lens off. That was also the case with my bike, but I did remove them with nothing broken. I assume they had some spot gluing at the factory, because they went back on with what I would call a solid (but not secure) feel. I ended up putting a couple small dabs of contact cement on them.
Streetiger is offline  
post #5 of 5 (permalink) Old 06-05-2019, 05:39 PM
Site Supporter
Formula Extreme
Main Motorcycle: 2017 Triumph T120
Lifetime Premium
 
Pudge's Avatar
 
Join Date: Aug 2016
Location: Atlanta, GA
Posts: 742
Quote:
Originally Posted by Streetiger View Post
I ended up putting a couple small dabs of contact cement on them.
A very good idea.

Clearview windshield, Triumph Cruise Control Kit DRL Type 2, Pazzo levers, JW Speaker Evo 2 LED headlamp, Booster Plug, Triumph LED indicators, 4 bar tank badges, chrome throttle body, clutch and inspection covers.
Pudge is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options
All posts must adhere to Forum Rules

Register Now



In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome