Trophy screen problems - Triumph Forum: Triumph Rat Motorcycle Forums
Trophy 1200 Triple This is a dedicated sub forum for the new Trophy triple.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-15-2019, 12:48 PM Thread Starter
Minitwins
Main Motorcycle: 2007 Triumph Sprint ST
New Member
 
Join Date: Apr 2017
Location: Southport UK
Posts: 13
Other Motorcycle: 2000 Aprilia RSV Mille
Garage
Trophy screen problems

Hi, i bought a 2013 trophy in november (so unfortunatly out of warranty)

and while i have had loads of trouble with the dealership(not a triumph dealership), the bike has been brilliant, however last week the screen just completly stopped working, not trying to move, nada.

I bought dealertool (useful to have) so plagged it in, and gave me a screen fault (duh) but even using the screen test function, nothing, screen refused to do anything.

I managed to get a second hand screen motor at a good price, so wacked that on, and gave all the external moving parts a good clean and made sure it was all free moving, but still nothing, again using dealertool.

first thing i checked was the fuse and thats fine, ive swapped around the relays (not just with each other) and still nothing

any ideas where to go next? im touring around europe next week and would really like a working screen for it

cheers

al
allannorman is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options
All posts must adhere to Forum Rules

Register Now



In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome