Battery issues - maybe?? - Page 2 - Triumph Forum: Triumph Rat Motorcycle Forums
Tiger 1050 - Mods & Workshop Workshop and technical talk for the 1050 Tiger

 2Likes
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 15 (permalink) Old 06-26-2019, 10:58 AM Thread Starter
Grand Prix 125
Main Motorcycle: Tiger 1050
New Member
 
GavinD's Avatar
 
Join Date: Oct 2013
Location: Glasgow
Posts: 27
OK, finally, finally hopefully got this fixed.
Stator was tested and was good.
The regulator / rectifier was shown to be faulty.

Working intermittently....I believe.

Currently been advised to fit the Triumph OEM (at twice the price of an "alternative" after market) part.....
Suppose paying for the warranty on the part.

And been assure that this will resolve all the issues.

Will update as and when....
GavinD is offline  
Sponsored Links
Advertisement
 
post #12 of 15 (permalink) Old 06-26-2019, 11:54 AM
SOTP Vintage Series
Main Motorcycle: '98 T595 Daytona
Senior Member
 
Join Date: Mar 2011
Location: Northern NJ US
Posts: 7,181
Other Motorcycle: 2014 Ninja 1000ABS
Unless the Triumph R/R is a MOSFET type, I wouldn't pay twice for it.
Cloudy likes this.
Felony is online now  
post #13 of 15 (permalink) Old 06-27-2019, 12:48 AM
Powerbike
Main Motorcycle: 07 Triumph Tiger 1050
Senior Member
 
Cloudy's Avatar
 
Join Date: Apr 2014
Location: New Zealand
Posts: 372
Extra Motorcycle: Triumph Bonneville se '13
As felony says get a Mosfet one, much, much better. I used a Ricks Motorsports one, plug and play. https://ricksmotorsportelectrics.com...ulator-10_005H

07 Tiger 1050,K&N Filter,Snorkel Removed,Storm GP Exhaust,20550 Frankentune Map,NGK Iridium Plugs,Ricks R/R,Ohlins Rear Shock,Ohlins Front Springs,Bar End Mirrors,LED Spots,Leather Seat Cover,Ebay Levers,Ebay Risers,Custom Bars.
Cloudy is online now  
 
post #14 of 15 (permalink) Old 07-22-2019, 12:44 PM Thread Starter
Grand Prix 125
Main Motorcycle: Tiger 1050
New Member
 
GavinD's Avatar
 
Join Date: Oct 2013
Location: Glasgow
Posts: 27
Ah! the joys.

Was aff Grid for a bit or twa..........
Stuff happening and not enough time to moan about it.

Anyhoo!

Investigations .........showed up that the stator - while working (aye right).
And the issue was with the rectifier.
This was taken off and checked (faffed)
Got the official Trium£h part and it worked a treat.

Bike was tested again, investigations .........showed up that the stator - while working (aye right) - was not pushing the full charge back to the battery.

Cover off, showed one coil burnt and another slightly singed.
A replacement was sourced of eBay for a fraction of a production part.

Bike now charging // starting // shouting like new lease of life..........

Here's hoping.
GavinD is offline  
post #15 of 15 (permalink) Old 07-22-2019, 01:00 PM Thread Starter
Grand Prix 125
Main Motorcycle: Tiger 1050
New Member
 
GavinD's Avatar
 
Join Date: Oct 2013
Location: Glasgow
Posts: 27
Was aff Grid for a bit or twa.......... well a few months.......
Stuff happening and not enough time to moan about it.

Anyhoo!
I now appear to have a working bike again.
Bike now charging // starting // shouting like new lease of life..........

My intentions as of ...when I finish my University.........is to get my hands more dirty than they have been in the past.
And do more to sort these things out myself.....
GavinD is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options
All posts must adhere to Forum Rules

Register Now



In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Timing marks and Tri Spark Ignition problem tjkoko Classic, Vintage & Veteran 58 11-09-2018 07:12 PM
fuse Bike2b3? Classic, Vintage & Veteran 16 09-28-2018 11:09 AM
2006 Speed4 Ignition and battery intermittent Issues CableGuy Air Cooled Cruisers - America, Speedmaster 1 09-03-2018 09:15 PM
help me wire my 1970 t120 650 cheapstreet Classic, Vintage & Veteran 20 12-09-2017 06:36 AM
Replacement Battery Colt3374 Water Cooled Twins Technical Talk 10 11-15-2017 05:28 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome