LT MAP Tubes and flat spot issue. - Page 2 - Triumph Forum: Triumph Rat Motorcycle Forums
Thunderbird Twin - Technical Talk Technical talk for the big Thunderbird twin

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 12 (permalink) Old 04-17-2019, 08:40 PM Thread Starter
Site Supporter
Grand Prix 125
Main Motorcycle: 2014 Thunderbird LT
Lifetime Premium
 
Scoobersteve's Avatar
 
Join Date: Sep 2012
Location: Albany, Western Australia
Posts: 37
Other Motorcycle: 2009 Suzuki Vstrom DL650
Garage
There are some good suggestions on here, thanks all. Will get it over to another Dyno dude and try a few things. May even remove the PC5, re-fit the O2 sensors and see how we go. Cheers

Die hard LT owner - you have to be with all the issues mine has had. :-)
Scoobersteve is offline  
Sponsored Links
Advertisement
 
post #12 of 12 (permalink) Old 04-18-2019, 09:14 AM
Formula Extreme
Main Motorcycle: 2014 T-Bird LT
Senior Member
 
slingshot60's Avatar
 
Join Date: Apr 2016
Location: USA
Posts: 655
Keep us posted on your findings. Just to make things right mine will cut out at highway speed between a gearshift change up or down when the idle speed is different.....and is intermittent as previously stated. One bad habit I may have done is max out the fuel tank upon a refill...perhaps causing fuel to go into the overflow tube. Bought my LT second hand with 2500 miles and the 4 screws holding the plate where the oil filter is were stripped. Suffice it to say previous maintenance history is unknown. Pulley bearing had to be replaced at 11k, 2 of the 4 plugs were oil fowled. Working on maintenance overhaul now and replaced plugs again DPR6 EA9 with standard gap. All 4 were nice and tan colored as should be. Replaced fuel filter last year with one from an auto store that was clamp able with seam in middle. Got the correct Mahle fuel filter and replaced it this year making sure I had the rubber intake cover in the right position....and it was. Remainder of maintenance should be completed today....so I can get it out to practice and renew the stale riding skills from winter dormancy.
slingshot60 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options
All posts must adhere to Forum Rules

Register Now



In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
MAP sensors on EFI Bonneville- Long post Forchetto Air Cooled Twins Technical Talk 173 06-11-2019 11:33 AM
MAP verses Morgo 750 kit sportsprint Classic, Vintage & Veteran 7 12-05-2015 07:01 PM
FIX–For The Unexpected Shutdown/Stalling Issue (long post) Faster Pastor Thunderbird Twin - Technical Talk 5 11-21-2013 02:51 PM
NEED tubes! & 'Forks by Franks' FattRat Air Cooled Twins Technical Talk 2 07-27-2006 02:21 PM
NEED tubes! & 'Forks by Frank' FattRat Club Cafe' 3 07-27-2006 12:57 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome