Check engine light. - Triumph Forum: Triumph Rat Motorcycle Forums
Thunderbird Cruiser Chat Cruiser chat for the the Thunderbird twin

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 02-08-2012, 09:53 AM Thread Starter
Grand Prix 250
Main Motorcycle: 1600 Thunderbird
Member
 
Join Date: Oct 2009
Location: Langhorne, Pa. USA
Posts: 58
Other Motorcycle: Honda 125 scooter
Check engine light.

Ok, I installed my heated grips according to the instructions. They work great but now my check engine light is on. When I first started the bike the fuel guage didn't work either. After riding a few miles the fuel guage started working correctly. I've re-started the bike a few times but the light is still on. Anybody have this problem? Anybody know how to fix it?
Backyard Bandit is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 02-16-2012, 01:20 PM
Grand Prix 500
Main Motorcycle: 2012 Red/Blk Thunderbird
Senior Member
 
Join Date: Oct 2003
Location: Lakeland, Florida
Posts: 150
Other Motorcycle: Always looking for one
Smile Engine light

Bandit: I had a similiar problem with the light. I installed some extra lights on my bike and interrupted the electrical system and removed some fuses. After I completed the work and everything worked OK I noticed the engine light on. This happened on two seperate occasions. Both times I had to ride the bike for several hours before the light would go off, almost two days on one time. One time I actually watched it slowly fade away.
Hopefully you will have the same experience I did and it will go out but not as soon as you would like.
BullClark is offline  
post #3 of 5 (permalink) Old 02-18-2012, 08:42 PM
Newbie
Main Motorcycle: Storm
New Member
 
Join Date: Feb 2012
Location: Uniontown United States
Posts: 4
I was told that the check engine light is set on a number of key cycles. The light stays on until a number of key cycles are reached without finding any problems ... then the light will go out.
NeonLeon is offline  
 
post #4 of 5 (permalink) Old 02-26-2012, 04:48 AM
Minitwins
New Member
 
Join Date: Jun 2010
Posts: 15
if your installation is ok and you have not disturbed anything like the vacumn hoses run the bike three times so that its up to working engine temperature each time you run it and cooled inbetween ech run.
if its still on after the three run cycles get it checked.
zolti is offline  
post #5 of 5 (permalink) Old 02-28-2012, 12:06 PM
Powerbike
Main Motorcycle: Trophy SE
Senior Member
 
Join Date: Mar 2010
Location: Gainesville, FL, USA
Posts: 356
Other Motorcycle: Honda CB900F 919
Extra Motorcycle: Honda CB750A Hondamatic
+1 on those vacuum hoses! When I did my 24k maintenance a couple of months ago, I didn't notice that one of the vacuum hoses had come loose during the put-back-together period of the maintenance, and after about thirty miles of riding my check engine light came on. The engine was still running fine, so I got to my destination and did a once over finding the culprit.

It took another couple of engine cycles to get the light to go out, but between then I hooked it up to the computer and took a look at what the error actually was, and that confirmed that it was the vacuum hose.

TuneECU will tell you what the light is on for, if you have an OBD2 cable handy.

Past Bikes:
2010 Triumph Thunderbird
2006 Suzuki Boulevard S50
Wells is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options
All posts must adhere to Forum Rules

Register Now



In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
02 Speed Triple - Check engine light ON, Fuel light ON, Oil Can Flashing Oil Light ON rogue1313 Speed Triple Forum 38 08-23-2012 11:54 AM
Check engine light and fuel light littlemanjr2 Daytona675 Forum 3 06-27-2011 12:00 PM
check engine light on Jay_Farrell Speed Triple Forum 7 05-07-2010 12:30 AM
Check engine light uscgmac Air Cooled Twins Technical Talk 2 11-30-2009 02:18 AM
Check engine light is on Lucky77 Air Cooled Twins Talk 6 06-28-2009 05:29 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome