Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

321 - 340 of 371 Posts

·
Registered
Joined
·
2,995 Posts
knowledge is power!! its great when you get an easy fix by taking the time to read something or others point it out!! glad you got it sorted out!!
 

·
Registered
Joined
·
105 Posts
I cannot load the drivers for the Lonelec cable. I am on an HP laptop running Windows 10 64-bit. I am disconnected from the internet and when I connect the cable nothing happens, install wizard does not start. No problem, I go to settings and launch the devices tab. It sees the cable, says there is an error (because I haven't loaded drivers). I double click as stated in step 4 of the initial post and all I get is a box asking if I want to disconnect the device. Absolutely no options to load drivers??!! Any help?
 

·
Registered
Joined
·
289 Posts
Go here http://www.ftdichip.com/Drivers/D2XX.htm scroll down to windows and click "setup executable" in the far right. It'll automatically download for you. Pay attention to where it was saved. Go to the file you downloaded (this is why you have to know where your computer saved it), right click on it and select run as administrator, and follow the steps. It'll automatically install the drivers for you.
 

Attachments

·
Registered
Joined
·
78 Posts
Great thread to follow for a first timer. Worked well. Did by the book eg cable etc and worked like a charm. I would absolutely recommend following the instructions verbatim. Great tutorial. Thanks a lot.
 

·
Registered
Joined
·
65 Posts
I'm about to change the tune on my 2015 R3T for the first time and this guide is going to be extremely helpful. In fact, I was hesitant to try this because of some of the confusing information about TuneECU that I had read until I found this thread.

Thanks much, Ebster! You're a true gentleman and a scholar! Seriously, you have clearly been a huge help to many people.
 

·
Registered
Joined
·
48 Posts
So I posted earlier yesterday about this, I did not see this neato guide. I am running windows 8. I downloaded the drivers (I was unable to open any of the files) I then connected the cable. It automatically downloaded the drivers. I go into device info and it shows that all drivers are working correctly. I have not attempted my tune yet. (im ordering that in a minute) For the people that have done this, Am I good to go? or should I download the drivers again but run as executive? as someone posted above.
 

·
Premium Member
Joined
·
2,425 Posts
You can check out connection to bike without needing a map. There are many readouts and diagnotic tests you can run without changing any map settings etc.

Just hook it up, turn ignition on and wait a min or so for the connect light to change from red, then amber then green.
Switch to Test or Diagnostic screens to see bike sensors, tach, Manifold Absolute Pressure (MAP) readings. Start bike to see these changing.
 

·
Registered
Joined
·
43 Posts
Hi all, new to the site and the Triple. Just wondering if anyone knows where I can download the TOD or contact Alain Fontaine. I have been to the TuneECU site but the version i need is for the MIVV exhaust and it's a private map which needs a payment to download. I don't mind paying for it however it seems the only way I can get a message through is via a Facebook page. I don't have and don't intend to get a Facebook account. Appreciate any help.
 

·
Registered
Joined
·
533 Posts
Useful thread, thanks. How reliable is the process to replace a map? My 955i is afflicted by a jerky on/off pick-up from closed throttle, this is awkward on ninety degree corners on backroads, but it can generally be lived with. Having read some of the tales of woe where issues are apparently unresolved (unless the poster has fixed the problem but not posted an update), I am wary of converting a usable bike to a non-starter.
 

·
Registered
Joined
·
85 Posts
If anyone needs one of these cables I have one for 15 shipped. I sold my triumph.

When I flashed mine had to make sure the battery was connected to a tender or charger to complete the process.

Sent from my SM-N950U using Tapatalk
 

·
Registered
Joined
·
63 Posts
Do we have a reliable process for using TuneECU specifically with a laptop running Windows 10 1803?

I last updated the map on my 2008 Sprint ST 1050 back in 2011 with an old Windows 7 laptop and all was fine. Trying to do it again with my Windows 10 laptop and I can't get a connection to the ECU. I still have the cable I used back then. Have tried both current versions of TuneECU and current FTDI drivers as well as the old TuneECU 1.82 that I used back in 2011 along with the drivers that I used back then too.

Also tried a Windows 7 VMware virtual machine on my Win10 laptop as an experiment but it won't connect either.

Tried all the usual suggestions...
- If VCP enabled then set COM port speed 921600 with software flow control
- Tried changing the COM port from 3 to 1 and 2.
- Tried disabling VCP in the USB device driver so the new version of TuneECU works more like the old one where the only interface available is the USB<->Serial.
- Pulled the headlight fuse and hooked up my trickle charger. Battery voltage with ignition and kill switch on is 12.95v, well above the 12.5 threshold.

The behaviour is as follows:
If TuneECU is attempting to connect using the USB<->Serial interface, I see 3 red light pulses, then after a delay of a few seconds, a bunch of quick orange flashes then it goes back to the 3 red light pulses and you don't see anymore orange. It will then continue to send out its regular pattern of the 3 red light pulses every few seconds until it times out connecting to the ECU.
If TuneECU is attempting to connect via Serial, I see consistent red light pulses every 1-2 seconds until it times out and says it can't connect to the ECU.

Any other ideas? Has anyone had reliable success with a Windows 10 laptop and TuneECU?

Cheers,
Dave
 

·
Premium Member
Joined
·
2,425 Posts
Sounds like you've tried a few things already. Didn't see mention of your antivirus/firewall settings. May need to ensure they are fully disabled prior to connecting cable.
I've had reliable W10 connections on my ultra book, but a friend had all sorts of trouble on his Surface Pro. I believed he solved it with a new cable, but doesn't make sense BC my known good cable would not work on his computer but did on mine.

I believe there was some tip about not letting windows automatically install drivers when first connecting cable? Need to browse manually to previously downloaded driver?
 

·
Registered
Joined
·
63 Posts
Yeah I've done all the usual a/v and firewall stuff and I manually installed every driver from 2008 till current but all exhibited the same behaviour. Interesting you mention someone else had trouble with a Surface Pro as I'm using a Surface Book.

The cable is fine as I managed to get my tune done via Android and USB OTG but I'd be keen to solve the Win10 issue as it may help someone else.
 

·
Premium Member
Joined
·
65 Posts
Dealer Tool

Do we have a reliable process for using TuneECU specifically with a laptop running Windows 10 1803?

I last updated the map on my 2008 Sprint ST 1050 back in 2011 with an old Windows 7 laptop and all was fine.
Any other ideas? Has anyone had reliable success with a Windows 10 laptop and TuneECU?

Cheers,
Dave
I'm having a similar situation with Dealer Tool connecting with my Sprint - nothing. Connects fine and works properly with my 2015 Trophy. Also using a refurbished HP Windows 10 laptop. Dealer 'updated' the tune a few years back and now the Sprint is harder to start and performance seems to have suffered.
 

·
Registered
Joined
·
21 Posts
Hello to all and sundry!

Recent owner of new to me 955i tiger and very pleased so far.

Anyway this is a question for a Valencian buddy of mine who can't help tampering. His Triumph is a 2016 TIGER 1200 XCA.

He's asked me to act as a translator.

He's wondering if there are any maps developed for decatted OEM headers and the recommended Arrow exhaust for the XCA which he had gutted. Second question is how to upload them to the bike's ECU.

He mentioned he is aware there is a fuelling map developed for the Arrow exhaust for OEM headers that still have the catalytic converter in situ.

He says she (the bike) loses low down power in Sport Mode.

Any info much appreciated.

Hope this is the right place to ask. Should I open a new thread somewhere in particular?

Triumph on...
 

·
Registered
Joined
·
1,882 Posts
Hello to all and sundry!

Recent owner of new to me 955i tiger and very pleased so far.

Anyway this is a question for a Valencian buddy of mine who can't help tampering. His Triumph is a 2016 TIGER 1200 XCA.

He's asked me to act as a translator.

He's wondering if there are any maps developed for decatted OEM headers and the recommended Arrow exhaust for the XCA which he had gutted. Second question is how to upload them to the bike's ECU.

He mentioned he is aware there is a fuelling map developed for the Arrow exhaust for OEM headers that still have the catalytic converter in situ.

He says she (the bike) loses low down power in Sport Mode.

Any info much appreciated.

Hope this is the right place to ask. Should I open a new thread somewhere in particular?

Triumph on...
I can't see any custom maps for the tiger 1200 xca on the tune ECU website, not sure if you've already looked.
There is also no triumph map specifically for the arrow exhaust, there is only one standard map which is designed to work with the standard exhaust or the arrow.
Unless anybody else has another source for custom tune ECU maps the only option is to get it mapped on a dyno, it's unusual that removing the cat will cause any loss of power though, especially only in one mode?
 
  • Like
Reactions: Auspanglish
321 - 340 of 371 Posts
Top