Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
My 2013 Triumph Trophy SE has just develoed a new irritating fault.

When I key on the fuel gauge reads zero, then after a couple of miles the fuel gauge begins to read. I know it takes time for the system to register a fill up, but it always used to read properly when keying on. Now I have to remember/hope that there is fuel in the tank.

Does anyone have any idea what causes this or better still how to fix it?
 

·
Administrator
Joined
·
19,459 Posts
Welcome to the forum!

The Trophy 1200 Triple forum is where you can connect with other Trophy riders. Introduce yourself there, post photos of your SE, and join the banter.

https://www.triumphrat.net/trophy-1200-triple/

Please complete your user profile so that we may see where you are from and what you ride as you post throughout the forums. Thanks!

http://www.triumphrat.net/profile.php?do=editprofile

Connect with local riders in the RAT forums. If you do not see a thread for your area, please start one.

http://www.triumphrat.net/rat/

You may also find local riders and local events in the Rides and Events forum.

http://www.triumphrat.net/rides-and-events/

Please share your home with us by posting photos of your rides in the Ride and Trip Reports forum.

http://www.triumphrat.net/ride-trip-reports/

Enjoy some off-topic and often humorous conversations in the Biker Hang Out forum.

http://www.triumphrat.net/biker-hang-out/

There is much to our forum, so please make yourself at home, browse the forums, and join the conversation where ever it may interest you.

Cheers!
 
1 - 2 of 2 Posts
Top