Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 10 of 10 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Has anybody any ideas for my problem!!. Left my Bike on Friday tucked up under its cover,Went to start it this morning and it blew its main fuse. the alarm is a data tag and is ok. the starter motor turns of when shorted. the looms look ok. any ideas before I strip the thing down!!
 

·
Premium Member
Joined
·
6,462 Posts
did it blow switching ignition on or when pressing starter ? Do you have a wiring diagram ? (If not, PM me & I'll scan one for you. Tell me year of the bike.)

Mike

(From M/cr originally)
 

·
Premium Member
Joined
·
6,462 Posts
as soon as the ignition is switched on.
Ok, so with the Haynes diag on page 9.24, the white wire coming off the ignition switch is #1 suspect for a short to ground. Follow that wire around & see what you can find. 1st unplugging the alternator plug (connector with brown & white heavier gauge pair) can eliminate (or otherwise) a fault inside the alternator.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #8 ·
OK cheers, that's a job for the weekend!! I will let you know how I go on. I don't want to put the old girl down just yet. (80,000 miles plus). thanks.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #9 ·
found the fault chaps, the alternator regulator is blown!!! will need to check the wiring still just to be on the safe side!!!! :)
 
1 - 10 of 10 Posts
Top