Triumph Rat Motorcycle Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
654 Posts
Discussion Starter #1
Hi all,

I've just collected my new (to me anyway) 06 speedy,its a little different from my previous "99 model. Anything in particular I should be looking out for ? I seem to recall somerhing about clutch cables being a problem.

J
 

·
Registered
Joined
·
1,869 Posts
If it's an early '06, you may have spongy front brakes. I don't. Other than that, I don't think there has been anything real common. I recently had my front rotors replaced in warranty due to inconsistant thickness, leading to pulsing. Not a huge deal, I put up with it for 13,000 + miles. I have also had a screwy idle speed problem from time to time, but they think the O2 sensor is the problem, and have one on order. The fuel vent canister valve (or whatever it is called) got plugged somehow, but the dealer just removed it, which pleased me just fine. Nothing has shaken loose after about 14,000 miles and two track days.
 

·
Registered
Joined
·
654 Posts
Discussion Starter #4
Thanks I'll check out the link. Has anyone else noticed that your helmet seems to have shrunk when you ride a triple,mines is definatley a size smaller,
or is it just that big sh*t eating grin !!!!!!
j
 

·
Registered
Joined
·
1,869 Posts
Has anyone else noticed that your helmet seems to have shrunk when you ride a triple,mines is definatley a size smaller,
or is it just that big sh*t eating grin !!!!!!
j
Sounds like a conspiracy. Thankfully, I bought a new helmet with Speedy, so I avoided that problem.:D
 
1 - 5 of 5 Posts
Top