Triumph Rat Motorcycle Forums banner

T509 Wont Start - ECU ????

16379 Views 16 Replies 7 Participants Last post by  DEcosse
I'm trying to get my friends 1996 T509 to start, as he is a single perent he can't rely afford to take to dealer. Basically I've got to the point where I think the ECU may be at fault. I'll give a basic review:
-Fuel pump initial prime has been gradually getting fainter.
- Bike now will not start, fuel pump does not prime but bike cranks OK. Stand up, clutch in, kill switch ok.
- Traced fuel pump rely not being pulled in, power available and if connected to live and earth rely operates OK.
- Tested pump by jumping rely to operate it and pump operates correctly.
- If I earth ECU return terminal to ground rely switches ok, so getting feed from ECU but not grounding return.
- If I jump rely to run pump and provide power to coils and crank bike it still will not start.
- I've checked earth's from ECU as they go to diagnostic plug and have continuity to battery earth
- I've tried to look for the earth connecter block, as mentioned in other posts, but can't find it. The primary earths from the battery seem to go straight into the loom and then to the alternator ground. there does not appear to be any connector blocks in the harness.
- I've removed the tank to ensure I've not missed anything.

Please help I'm now at a loss other then either to take to dealer to check or try to get a second hand ECU to try.:confused:
1 - 17 of 17 Posts
blades n birds, I've posted a link to the thread in the T3 section...they're more used to these carb'd bikes.

bradtx said:
I've posted a link to the thread in the T3 section...they're more used to these carb'd bikes.
:) AFAIK a '96 T509 is fuel injected.
There is no such animal - if a 96 it's a T3 and carb'd, if a T509, it's a '97 and FI.

But since the OP is talking about fuel pump, then it presumably IS a T509, just misidentified the year, not the model.

blades n birds - it appears that the very early T509 (& T595 Daytona) did not have the earth block - which is something I only recently discovered myself!
Now - one thing to recognize when trouble-shooting the fuel pump relay circuit, is that you get the initial 'ground' for the fuel pump relay for only 3 seconds after ignition-on; so attempting to diagnose outside of that window is futile. The ECM relay drive signal then does not come back until after the crank signal is received and re-initiates it.
I would say that ECM failures are rare - but never say never.

So the first question is - do you get the pump/coils/injector power for that initial 3 secs at ignition on?
Since you still do not start when the relay is jumped, then you possibly have a a problem with the crank sensor (or cam sensor I think also comes into play on that model)
See less See more
Cheers guys for the response. My mate's bike is a 'P' reg I just assumed '96 but from what your saying and what I've read elsewhere it must be '97. Sorry for confusion. The fuel pump rely is not being pulled in for the initial 3 secs as I've tested the pump by jumping the relay and it runs fine. If there is a fault with either the crank sensor or cam sensor would this stop the initial pump run. Is there a way of checking these sensors, i.e. resistance, ect or bump starting bike?
Check the ECM relay - that one provides power to the injectors but also to the ECM
That should be the one in front row, in left-most position (#7)
Swap it with the cooling fan relay & see if that changes anything.

See less See more
I'm sure this relay was making correctly, but I will double check. Is there a way to check the cam and crank sensors?
The crank & cam sensor would not stop the Fuel Relay from coming on for the 3 sec timer.

I'm experimenting the same problem as Blades n birds with my t595 1998...I went thru the same trouble shooting steps.

I have a bad ground coming out of my ecu to my relays, around 10v, not enough to clip my relays, but the positive is ok (around 12.5v). If I bypass the ecu all my relays are working, the fuel pump is running. The fuel pump doesn’t run when I turn the key. I'm really starting to think that is my ECU (and it pisses me off due to the price it costs!!!). Anybody as an idea of what it could be?


Check to see if you have one of these in your bike (the earlier models did not)
- it is the infamous ground block - cause of many electrical issues.

There are several iterations of this device - the latest is the one shown in the bottom picture, and identifiable by the second ground wire/lug on the negative battery terminal.
If you do not have this second wire would recommend upgrade to this latest type.

The problem is it gets arced out and has an insufficient grounding path to the battery

There is a kit available to repair/upgrade - has an additional grounding cable that goes directly to the battery post.

Triumph Part number is T2505055

See less See more
I will have a look this evening...thanks, I will keep you inform!


Finally I found the problem, one of the pin in the ECU connector was oxidised and was cut flush with the module box. I was able to dig around with my Dremel and weld a home made pin made with a small copper wire filled with tin solder. Than I shaped it with my Dremel in order to have a good fit into the connector. Now it works perfectly, I hope the welding will hold on!

Thanks every body for your help!

hello Blades and birds,

it seems i have a problem which looks like yours,
how did you solve it?
The OP Blades n birds has total of 4 posts and last activity 3 years ago - you will not receive a reply to this - keep our questions in your primary thread.
Hi. It was a friends bike I was fixing. In the end I got a second hand ECU which solved that problem. He had a few other issues with it and finally got it fixed and chopped it in for a newer street triple before anything else went wrong.
Why can’t I see this picture?
Because the thread is 10 years old and the site has gone through countless 'upgrades' since then
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.