Triumph Rat Motorcycle Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Facing a problem with my WC street twin. My bike refuses to start. It cranks but doesn't start. I have uploaded a video as well -
https://youtu.be/sN71WkWUJ-8

I thought that the battery might have gone kaput so tried to jumpstart it using my car battery but still the same result.Now the low fuel indicator lamp has also started showing up. Here is the pic - https://ibb.co/Xxnmk2H

Any idea why is this happening?
 

·
Registered
Joined
·
490 Posts
It's not the clutch switch if it's cranking.
That seems like straightforward low battery voltage, the ECU is stopping the starting sequence and resetting the clocks.
If it's still doing it with a car battery jump start then there may be a loose connection somewhere.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
It's not the clutch switch if it's cranking.
That seems like straightforward low battery voltage, the ECU is stopping the starting sequence and resetting the clocks.
If it's still doing it with a car battery jump start then there may be a loose connection somewhere.
Yeah i tried jumping with a car battery. It still doesn't start. Now the low fuel lamp has turned on. The digital meter however doesn't show fuel levels either.

Also when i cranked it without the car jumper. The voltage reading on the multimeter was 8-8.5 volts. So maybe the battery is dead?
 

·
Registered
Joined
·
490 Posts
Yeah i tried jumping with a car battery. It still doesn't start. Now the low fuel lamp has turned on. The digital meter however doesn't show fuel levels either.

Also when i cranked it without the car jumper. The voltage reading on the multimeter was 8-8.5 volts. So maybe the battery is dead?
It does sound like your battery is dead, I would buy a new one and try it again, you're going to need a new one anyway.
Have you tried it connected to the car battery on its own with your battery disconnected?
 
1 - 7 of 7 Posts
Top