Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 13 of 13 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Hi - I am attempting to use TuneECU to reset the service interval on my 2019 Street Twin. Did this twice before via Bluetooth connection, and then got a new Android device. Now I get an error after it connects, saying that I dont have a compatible map loaded. I tried loading different maps from here but keep getting the same error.

Anyone see this before? I'm not trying to load a new map - just simply want to reset my service indicator.

Thanks all in advance...
 

·
Registered
2018 Triumph T120 2020 BMW R1250R
Joined
·
911 Posts
"then got a new Android device. Now I get an error after it connects, saying that I dont have a compatible map loaded."

I'm guessing it is the "new" device"...? I could be wrong.

I know I tried a Fire tablet (classified as an Android device) from Amazon and it did not work. I can't remember specifically what didn't work but I sent it back.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #3 ·
New device, yes. Cheap LG thing. TuneECU runs fine, and connects to the OBDLink MX+, but then I get the error and I can’t access any diags or any other features.
 

·
Premium Member
Joined
·
1,823 Posts
Try downloading the maps from here:


The map files on the box site are 896kb. The map files from the tuneecu.net site, which you can read into the windows version, are much smaller, at least for the bikes I’ve looked at.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #7 ·
So looks like the maps worked (thanks!) but now I get a message asking if I want to execute an ECU recovery. I've added an xpipe and a booster plug, but never touched the ECU mapping. I'm afraid if I execute the recovery I'll screw something up. Has this happened to anyone before? Is this just pulling from the ECU, or will it attempt to reprogram it?
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #8 ·

·
Registered
Joined
·
114 Posts
Make sure your kill switch is in the run position. I got these errors when my starter button/kill switch was in the off position. It shits everything down. They also suggest pulling the headlight fuse and put on a charger.
 

·
Premium Member
Joined
·
1,823 Posts
So I'm hesitatnt to do this - should I be worried about locking up my ECU?
You can’t read maps from the ecu on the water cooled bikes. Did you start a download to the ECU which didn’t complete? If not, you don’t need to recover. If yes, you do.

PS, if you tried connect without a compatible map loaded in the program, something could have gotten screwed up in the program. Is the bike starting and running OK?
 

·
Registered
Joined
·
114 Posts
Yeah, the kill switch kills a lot more than just the ignition. It is almost like turning the key off. That one had me for a while. I was getting pissed. Hooked it up to the truck and everything worked so then I went back to the bike and figured it out. Too many beers on a Friday night before deciding to tune it!
 
1 - 13 of 13 Posts
Top