Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Not sure if it's related, I removed the fuel tank to change an air filter. Put all back together and now the bike won't fire up... Cranks fine then battery goes. It was running fine before the tank removal. It did initially run a couple of times after I put everything back together but would conk out when using the throttle. I did have to replace the air line to the ecu. I'm now really confused although I have found 2 spare connectors under fuel tank ... Are these related? Pic attached. The fuel pump appears to be working and fuel is covering the pump.

It's a 2002 sprint st ... If anyone could help that'll be awesome as I am a rider returning to riding after 25 years and not had a chance to go out yet!

Much obliged Chris
 

Attachments

·
Registered
Joined
·
255 Posts
I dunno what they are but in your second pic it looks like the wire to the plug has rubbed through due to that jubilee clip. Probably isn't doing anything but I'd sort it while you're in there.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Good shout ... I think it's the secondary air intake. Still can't find the cause of the non starting:(
 

·
Registered
Joined
·
255 Posts
What's it do/not do when it doesn't start?

Does it spin over etc?



Ignore that, just read your first post properly.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
So since reassembling the tank I got it to start but only on throttle, idle would conk out. I haven't managed to start it since. Fuel pump is working and I assume spark due to starting previously.
 

·
Registered
Joined
·
255 Posts
I'd suspect the MAP sensor then, that's the one that has the vacuum pipes from the throttle bodies to it. It's only used at idle & low throttle/revs to fine tune the fuelling. Double check it's plugged in & the vacuum hoses are connected properly.
 

·
Registered
Joined
·
255 Posts
I don't know on the ST sorry.

I've got a GT & it's on top of the airbox, I'm pretty sure I've read it's in a different place on a ST though.
 
1 - 9 of 9 Posts
Top