Triumph Rat Motorcycle Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
hi hope someone can help my rear light and numberplate light aint working break light works no tail light checked fuse thats ok wiring diagram states yellow wire is shared with rear light and numberplate light been told to check the earth which should be attached to frame but cant find it does anyone know where it is or any other idea what the problem is its an 06 plate would appreciate any help thanks sean
 

·
Registered
Joined
·
19 Posts
I am having the same problem with my Sprint, different years could mean different problems, but I just keep blowing the fuse. Oh and the fuse controlling the running tail light was not what the fuse chart said it was. I just kept testing till I found one that was blown and replaced it. Then the new one blew, so I need to figure out what my overlying problem is....:(
 

·
Registered
Joined
·
2 Posts
Sprint tailight problems.....

I heard of a few being bad right from the factory,if it's within two years get a new one under warrantee. I heard the heat from the exhaust plays havock with the led circiuts:eek:
 

·
Registered
Joined
·
2,103 Posts
I heard of a few being bad right from the factory,if it's within two years get a new one under warrantee. I heard the heat from the exhaust plays havock with the led circiuts:eek:
Hey Joe

I had mine disintegrate just below the exhaust outlets- it happened TWICE on my '06, which was Sunset Red...just like yours....the dealer replaced it no problem both times...the lights worked but the clear plastic self- destructed...
 

·
Premium Member
Joined
·
9,047 Posts
You might get some suggestions re your light problems in this section of the forum but I think you stand a better chance of getting more hits and replies if you re-post your question in the general section of the Sprint forum.
 
1 - 6 of 6 Posts
Top