Triumph Rat Motorcycle Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello everyone, my speed triple r is making a sound after turning ignition on. It also remains for few seconds after turning ignition completely off for. Check my video. Anyone know what’s that? How to fix it? Anyone got same problem ? Greeting someone https://m.youtube.com/watch?v=D9j_nV4Q2GY
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Are You sure there’s nothing to worry about ? I got this bike for two weeks and I didn’t noticed that earlier. First time I heard it was after washing(maybe I didn’t notice that sound but it was from beginning) it so I thought water get in and making trouble with electronics.
 

·
Registered
Joined
·
2,013 Posts
As the stepper is on the right side you should hear it louder on the right. The stepper self calibrates a few seconds after the engine is shut down. The noise may be different between 1050 years and models though.

The pump priming is occurring when the key is turned on and it's a different noise that last around 5 sec. If you stick your ear to the tanks you'll feel it better.


Fred
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
This noice last till I turn ignition off and even few seconds more. So what do u think everything is fine ?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
I don’t know if I uderstand you right, you say that this is not the voice of pump priming ? So what’s that? It requires repairing or something ?
 

·
Registered
Joined
·
1,261 Posts
That's definitely the throttle actuator motor as others have said, even though you're not twisting the throttle the motor is still active trying to maintain its position, if you open the throttle you'll hear the noise changing as the motor turns, my Thruxton makes exactly the same noise. Some may be louder than others depending on backlash in the system and so on.
 

·
Registered
Joined
·
1,261 Posts
So should i leave it like that?
Yes, if there was a problem with a throttle actuator or sensor you would have a malfunction light.
also it's probably not a good idea to leave the ignition on for any length of time without the engine running, I think it mentions it in the owner's manual.
 
1 - 10 of 10 Posts
Top