Triumph Rat Motorcycle Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey triumphrats. I've had a problem for a while. I'm not sure if it's been covered in other posts but if so, please send me the link. I have a 2009 speed triple that I bought a while ago. The previous owner mentioned that the ecu was fried so I got one as soon as I got the bike. It didn't help coz the bike still doesn't start. Later I found out the speedo was fried as well. I've tried to get an 09 speedo cluster but I haven't been successful.

I'm in Nairobi, Kenya so visiting a dealer isn't an option for me. My only help has been ebay where I got the ecu shipped to me but not much else. I've read conflicting info concerning aftermarket clocks and it's only made me more confused. I wouldn't want to spend more money buying parts that wouldn't work considering reselling them from here is a nightmare. Please help, I've had this bike for 2 years and I've never even heard those sweet beowulf end cans growl. Much appreciated
 

·
Administrator
Joined
·
19,459 Posts
Welcome to the forum!

The Speed Triple forum is where you can connect with other Speed Triple riders. The folks there will have the knowledge and experience to assist you. Introduce yourself there, post photos of your Speed Triple, and engage the members.

http://www.triumphrat.net/water-cooled-twins-talk/

Please complete your user profile so that we may see where you are from and what you ride as you post throughout the forums. Thanks!

http://www.triumphrat.net/profile.php?do=editprofile

Please share your home with us by posting photos of your rides in the Ride and Trip Reports forum.

http://www.triumphrat.net/ride-trip-reports/

Enjoy some off-topic and often humorous conversations in the Biker Hang Out forum.

http://www.triumphrat.net/biker-hang-out/

There is much to our forum, so please make yourself at home, browse the forums, and join the conversation where ever it may interest you.

Cheers!
 
1 - 2 of 2 Posts
Top