Triumph Rat Motorcycle Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
382 Posts
Discussion Starter #1
I have recently noticed that the throttle is a little snatchy especially in the midrange. And when I turned my bike on this morning the idle speed was higher than usual#2k rpm.
Does this ring any bells?

I thought I might do the adaptation cycle thingy.

Any other ideas?
 

·
Registered
Joined
·
382 Posts
Discussion Starter #3 (Edited)
Which model, what year? Could be the IACV.
Sorry! probably should have mentioned that.
2006 with 16k miles.

Does TuneECU actually "balance" the throttle bodies or does that require a physical adjustment to be made to achieve this?

I have done the SIA delete with the block off plates.

All was working well until the past few weeks and nothing significant has changed.
 

·
Registered
Joined
·
898 Posts
Sorry! probably should have mentioned that.
2006 with 16k miles.

Does TuneECU actually "balance" the throttle bodies or does that require a physical adjustment to be made to achieve this?

I have done the SIA delete with the block off plates.

All was working well until the past few weeks and nothing significant has changed.
Balancing is done by you...tune ecu just gives you the readings.

With your idle check all vacuum hoses on the air box to ensure none are lose or have come off.


Sent from my SM-G930F using Tapatalk
 

·
Registered
Joined
·
2,975 Posts
Within 10 of each other is fine, even if they are within 20 i might not go through the trouble of adjusting.

I second looking for a vacuum leak. What are your TB readings from the map sensor for all 3 cylinders?
 

·
Registered
Joined
·
382 Posts
Discussion Starter #7
Just done the adaptation cycle and it seemed a little uneven with slight surging whilst idling.
Which pipes do I need to be checking for leaks in and how is this best done?
 

·
Registered
Joined
·
382 Posts
Discussion Starter #8 (Edited)
Plugged in TuneECU.
When I switched the engine on the three cylinders read 600/590/600 at idle. I presume this seems to suggest the throttle bodies are balanced???
 

·
Registered
Joined
·
2,975 Posts
They are balanced, not sure what normal range is though, mine were reading closer to 700 when I did them the other day so may be a little low. You are really looking at all of the rubber vacuum lines around the airbox and TB. Also check they are both seated correctly.
 
1 - 10 of 10 Posts
Top