Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 8 of 8 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Hi Guys,
Hoping someone can help me diagnose two little issues I am having with my 98 Daytona t595

The first is a rather sluggish start no matter hot or cold, it just turns over for about 5 to 10 seconds and then starts. The battery is fully charged and I can hear the fuel pump priming fine so I am not sure what the problem is.

The second issue is a new one, I was cruising on the motorway at a respectable 50-60mph and the bike coughed and lost power for a second and the engine management light came on for about 3 seconds. Its only happened about 4 times but its always while going at a steady speed and I am planning on the bike on a bit of a tour in about two weeks and I want to get all the niggles sorted out before hand.

Thanks in advance.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #2
Oh and I forgot to mention I connected it to ECU tune and I got no error codes and the map looks ok. If someone can suggest a better map for a 955i with a high Carbon Race exhaust and K&N filter I would appreciate it.
 

·
Registered
Joined
·
293 Posts
Those are trouble sign's alright,and they don't inspire confidence when trying to ride either,perhap's zeroing the TPS would help matter's,it's strage that no code's come up.The TuneECU website has some map's for your T-595,check them out.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #4
Those are trouble sign's alright,and they don't inspire confidence when trying to ride either,perhap's zeroing the TPS would help matter's,it's strage that no code's come up.The TuneECU website has some map's for your T-595,check them out.
Yea its quite unnerving when you are in the middle of nowhere and the bike dies even if is just for a second. I did reset the TPS using ECU tune but unlike the instructions the TPS light didn't go green afterwards.
I went through all the maps from ECU website and none of them have the combination of High level Race exhaust with K&N.

Part of me is wondering would it be better to but it back to the OEM map...
 

·
Registered
Joined
·
293 Posts
How bad does your bike run with it's current tune?From what I read a good dyno tuning is really the best way to get optimal result's,anything else is rather generic.I also read in the EFI forum that Triumph is receiving alot of ECM's that owner's assume are bad but really aren't found so after a factory inspection,just lot's of over written map's.Your pipe look's simular to a T.O.R.S. pipe,maybe try a factory tune?
 

·
Registered
Joined
·
21 Posts
Discussion Starter #6
I have MAP 9863 (T595 Daytona with high aftermarket exhaust (TORS)and new cam timing (no wheel sensor) on it at the moment.
I have to bring it in to Triumph Dublin for a recall fix so I guess I will have to ask them to check it out.
 
1 - 8 of 8 Posts
Top