Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of September's Bike of the Month Challenge!
1 - 11 of 11 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 · (Edited)
So the Tiger has been running rough. Hard to get it up to speed and pokey acceleration. So I pulled the tank and air box (first time as I'm a new owner) and discovered that two of the three coils appear to be corroded and the casings split!!

Any suggestions on where I might be able to order a new set?

Is this Common with the '06 Tigers? Almost 46K on the ticker

Thanks guys
Chris
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #4 ·
Are there good pictures? How's the return policy?
Good pics and he guarantees his product . They go for $132.00 new. I got free three day shipping too. I went for it. Will see how they do. New iridium plugs as well. Can't wait to get the bike back on the road
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #5 ·
What would cause the coils to fail as they did? Are these faulty parts or pilot error by the previous owner?
 

·
Premium Member
Joined
·
3,018 Posts
Just old I'd assume. The heat finally got to the plastic and cracked it then moisture got in and ruined them.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #9 ·
Yep!
Got the new parts in Thursday and replaced the old coils, plugs and air filter and she runs like a top!!!

Chris
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #11 ·
Well, ran good for two days, still better than before but now the bike jerks a bit in all gears... Kind of pulses? Any ideas?
 
1 - 11 of 11 Posts
Top