Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 3 of 3 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Hi,

I was riding in a demo last night in London and the displays on my S4 went mad and started flashing. I pulled over and thought that it had just overheated. Both the engine light and the oil light came on.

After charging the battery from a recovery vehicle the oil was checked and was topped up, but the engine light is still on. I was told the following codes:

P0230 & P1231

Something to do with the fuel pump. The bike has been working fine with no signs of any problems. I managed to get it home without paying for recovery, but wondered if anyone had any ideas. It is on a 03 plate.

Thanks in advance
 

·
Registered
Joined
·
347 Posts
P0230 indicates a fuel pump system fault.
P1231 indicates the problem is/was a a short or an open circuit earth.

Can't be of any more help, sorry. I assume the fuel pump is working since you got home and I don't know anything about checking wiring other than looking at the wires and checking there's no holes in them.

If it was a 'glitch', the engine light should go out after three hot/cold cycles.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #3 ·
I have had the bike checked over and it was a faulty battery. It was running at 9 volts which caused the computer to send unrelated error messages.

All fixed and back on the road. :D
 
1 - 3 of 3 Posts
Top