Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
944 Posts
Discussion Starter · #1 ·
As the title suggests, I've seemed to have lost the rivets bolting the ignition to the triple clamp.

Besides the obvious mystery on how I lost them, it looks to be a simple case of shooting new rivets. If so, what size should I get? I have a Craftsman rivet gun and rivets up to 1/8 x 1/8, but I think I need something bigger.

Sucks that I'll need to remove the fairings to really get at it with the rivet gun.
 

·
Premium Member
Joined
·
16,670 Posts
AFAIK, the ignition should be bolted to the yoke with special security bolts that shear off when you attempt to remove them. Bike Bandit lists them as M6x1.0x20mm. If it were me, I would replace them with stainless socket heads with blue Loc-tite. If you're lucky, maybe the old bolts will have fallen out completely and this will actually be a lot simpler than you expected.

Have a look over in the Sprint forum; you're not the first person this has happened to.

Cheers,
-Kit
 

·
Registered
Joined
·
944 Posts
Discussion Starter · #3 ·
Thanks. I kept referring them to rivets which is why I was having trouble finding relevant information. I'll look up the part on BikeBandit and see what we're talking about.

I'm guessing that whatever was securing the ignition is gone, as there is nothing holding it in place. Unfortunately, without taking the fairings off, its a odd angle for getting a good luck. Good thing we have a dentist mirror.
 

·
Registered
Joined
·
944 Posts
Discussion Starter · #4 ·
Hey KitNYC,

Just wanted to follow up and say thank you for the clue, you gave me a ways back. I was able to perform a more accurate search and found the needed information, in no time.

Took me longer to get my lazy butt to the local Home Depot and pickup a couple M6x20 hex bolts and lock washers. It's tight, plus I have a spare when I notice the left bolt is missing.

Thanks again!
 

·
Premium Member
Joined
·
16,670 Posts
No problem, glad to hear you got it sorted! I probably would have thought of the lock washers about the time I started screwing in the bolts, rather than when I was actually at the store.

Cheers,
-Kit
 
1 - 5 of 5 Posts
Top