Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
For those of you who are mechanically inclined i could use your knowledge for an electrical issue. I am looking for help to identify the missing part in the photo bellow.




My turn signals all stopped working on the ride home and when i started looking around I saw a torn rubber retainer (left side on the frame next to faring) I pushed up to the head light to get a photo and this loose connector missing something. I know it is in the electrical section but looking around in the schematic I am unable to be sure what i should be replacing.

Thank you in advance

Cheers
 

·
Super Moderator
Joined
·
8,838 Posts
I don't know off the top of my head, but my guess is you lost the blinker relay. I can't see from the photo, but if the connector has three slots for knife connectors at right angles, I'd bet dollars to doughnuts you lost the relay. They are cheap from an auto parts house. If you use LEDs, you will need to use an electronic relay or it will blink rapidly. I'm not sure how may different varieties there are, but I'm pretty sure you will find what you need. I recall something about using one intended for a Volkswagen, but it might be some other relay. I hope a better informed person can pipe up to correct me if I've just sent you down a rabbit hole.
 
1 - 2 of 2 Posts
Top