Triumph Rat Motorcycle Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi.
I am currently rebuilding the top end of my 1965 Tiger100, the seals that were fitted to the top and bottom of the push rod tubes were a white rubber discs which were leaking slightly.
I have been given red O rings as replacements and am wondering whether I should use any type of sealant with them? any advice would be appreciated. :)
 

·
Registered
Joined
·
348 Posts
are you talking about (VITON O RING)

IF so i use nothing but motor oil to coat them.

keeps them from getting cut when putting tube together
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Hi.
Not sure on make of ring I thought Viton were black, and the red ones were silicone.
Will try fitting with oil as you say.
Thanks for the advice.
 

·
Registered
Joined
·
348 Posts
your talking about the o ring that on top of the tube (pushs in head)?

viton is just a type, very good o rings, could be any color
the package of o ring would have said viton use on top or something like that
 

·
Registered
Joined
·
348 Posts
as far as orings i always just use oil to coat.

if you use silcone or any thing like that it is just masking a problem.

clean area very good (like hospital clean) make sure everything is round, or flat, straight. and put back to together.

i don't use silcone only because if you get any that comes lose of falls off later and works it ways into oil system then, well your looking at a lot more $$$ and time. when just taking a couple more minutes to clean and assemble the first time.
 
1 - 6 of 6 Posts
Top