Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi everyone,

I have 1988 Speed Triple and have a small overheating problem. The bike runs great, does not have any problems when ideling, or loss of power, but if I sit in traffic for too long it starts to run very hot, or so does my gage say. The other day it jumped up very close to the red, but never seen it in the red it always just stays below it. When I start going again even at 10mph it goes back down almost instantly. The fan workes fine and the coolant is good to go. Would I know if I did any damage do to the motor running hot or am I ok? Like I said the bike is running strong and there is no loss of power or anything, just was sitting in traffic for some time.

If someone can help that would be great. Thanks everyone for your time.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #2 ·
Hi everyone,

I have 1988 Speed Triple and have a small overheating problem. The bike runs great, does not have any problems when ideling, or loss of power, but if I sit in traffic for too long it starts to run very hot, or so does my gage say. The other day it jumped up very close to the red, but never seen it in the red it always just stays below it. When I start going again even at 10mph it goes back down almost instantly. The fan workes fine and the coolant is good to go. Would I know if I did any damage do to the motor running hot or am I ok? Like I said the bike is running strong and there is no loss of power or anything, just was sitting in traffic for some time.

If someone can help that would be great. Thanks everyone for your time.
Sorry every one typo a 1998 Speed Triple T509 thanks.
 

·
Registered
Joined
·
164 Posts
It'sprobably nothing to worry about. They all run hot if you're making a comparison with a jap bike. As long as it doesn't go into the red and stay there it's fine. It doesn't take long to see the temp go up in traffic, they're known for it. You said yourself it didn't go in the red and it went down when you started moving.
The worst I've seen for this was my Speed 4 but it was normal just like the two triples I've had since.
 

·
Registered
Joined
·
47 Posts
I have no experience with that model at all but I doubt you have anything to worry about. The gauge didn't go into the red.

The bike was running fine by your account, obviously if engine behaviour changes you need to think about taking action like shutting it down and getting it checked out.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Thanks every one. Yea it never went in to the red the fan workes fine and the coolent is good. There is no diffirence in the engine sound, or the power out put and it dropes back down almost instantly after taking off. And yes I was looking at the japanese bikes for temp. reference.


Thanks again. I am new to bike mechanics, but if you have any car problems let me know.
 

·
Banned
Joined
·
557 Posts
Quick and cheap insurance!

1) New radiator cap. If losing some pressure via the cap it can run hot.

2) Flush system and replace coolant with "Engine Ice." it will run cooler.

3) Thermostat could be going bad and siezing a bit/ not opening all the way. It's cheap and EASY as all hell to swap in.

4) "Burp" the coolant. If there's an air bubble in the system it will run hot.

The bike is old so the cap and thermostat could most likely benefit from being replaced.
 
1 - 8 of 8 Posts
Top