Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of October's Bike of the Month Challenge!
1 - 8 of 8 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Hello,
I just bought a 02 Daytona. The bike is pretty stock, but the previous owner did swap out the stock turn signals to low profile led ones. I am pretty sure when I picked up the bike that the turn signals worked, but now the right side signals are fine and the left side ones don't blink. Instead the signals stay illuminated and the dash indicator also stays illuminated. There is also a buzzing from the tail section of the bike when the left side signals are on. There is a normal clicking sould of a relay when the right hand signals are on.

Any thoughts?
 

·
Premium Member
Joined
·
3,434 Posts
imarcr2, Unless the led has shorted the most likely cause is the wiring. The buzzing sound is likely the turn signal relay.

Brad
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #4 ·
I hate wiring, but I will track it down. Couldn't hear the buzzing when i was actually riding the bike....just the howl of the triple:D

Bill
 

·
Premium Member
Joined
·
3,434 Posts
Bill, Don't worry about the buzzing relay. That'll stop once the trouble is fixed. The problem is most likely just a few inchs inside the fairing.

Brad
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #6 ·
Turned out to be the wiring for the aftermarket turn signals. I was very close to getting ribbed from my Japanese bike owning friends for the typical "brit bike with electrical problems....lucas prince of darkness stuff"

Bill
 

·
Premium Member
Joined
·
3,434 Posts
Bill, You can tell your buds that your Triumph has the same Japanese electrics they have. Thanks for reporting the fix.

Brad
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #8 ·
Brad,

They made the English joke right until they heard that howling triple. Not sure if that shut them up, or if I couldn't hear them over the engine!
 
1 - 8 of 8 Posts
Top