Triumph Rat Motorcycle Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey everyone. I just upgraded to 2020 Street Triple RS (from 2010 Street Triple) and had them put the Bluetooth module on it.

So I get it home and tried to pair up the my triumph app and I’m having trouble that maybe someone has already figured out.

I can pair my iPhone to the bike fine and have been able to pair my Senna so I can listen to music and make calls. However, when I use the my triumph app to enable navigation nothing happens.

I’m expecting to see a confirmation show up on the bike’s screen. I am in the regular dash mode, not menu mode, like the instructions say. I’ve even tried running the bike in case that had an effect.

Thanks in advance for any help!
 

·
Registered
Joined
·
28 Posts
No idea, but have you checked the FAQs here?


This one may be relevant:

NAVIGATION DOES NOT WORK ON MY IPHONE, BUT ALL OTHER FUNCTIONALITY WORKS CORRECTLY
iOS devices use two Bluetooth connections: one for music, calls and messages; and one for navigation. Both must be connected in order to use the app and the navigation functionality. Make sure the iOS pairing instructions have been followed completely, including the stage to “enable” navigation within the My Triumph app. This “enable” stage makes the second Bluetooth connection, and can only be completed following the main pairing operation.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks for responding. When I follow the instructions and click the enable navigation button from my triumph app I get a swirly logo showing its working but nothing else. Eventually it gives me an error that the connection timed out.
From what I’ve read, I should see a confirmation on the bike that I select to complete the pairing.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
OK. I figured it out. It turns out that the Bluetooth name identifying your iPhone must be between 5 and 20 characters and mine was too long.

The fix was to change the name of my phone to something shorter and reinstall + reboot and start over from the beginning. This time the confirmation shows up on the instruments and I’m able to complete the pairing.
 
1 - 5 of 5 Posts
Top