Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
its a 1998 Trophy 1200
The oil light came on today,reel low not very bright and win I turn off the key and re start the light will go out for 2 min or so and it will come back on not very bright. PS it rain on it a lot yesterday .
Has anyone had this before ? Thanks Corbin and oil is at the right level.
 

·
Registered
Joined
·
653 Posts
What is your idle RPM? If it should be around 1000-1100.
BTW the oil light is a LOW Pressure indicator not low quantity. My bike will do this also if idling too low.
Mark
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
What is your idle RPM? If it should be around 1000-1100.
BTW the oil light is a LOW Pressure indicator not low quantity. My bike will do this also if idling too low.
Mark
Thanks for your replay,
The RPM is 1000 to 1100 , but it will come on at 4500 RPM , so I then off the bike and then it on and the light go off some times 15 or 20 miles and comes back on at 45 MPH to 80 MPH , , and today rode 67 miles and light came 1 time
 

·
Registered
Joined
·
348 Posts
There must be someway to check the pressure.
These bikes have grounding issues. in the instrument consoles.
I'd spend the time finding out, weak pressure and the main bearings may not be getting oil. It takes pressure to force oil thru the galleries in the cranckshaft.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
There must be someway to check the pressure.
These bikes have grounding issues. in the instrument consoles.
I'd spend the time finding out, weak pressure and the main bearings may not be getting oil. It takes pressure to force oil thru the galleries in the cranckshaft.
Thanks,
i thank it is a bad ground to, the light is so deam. or the Oil Sending unit. it comes and go. and did not have any of sing be for it got rain on.
 

·
Registered
Joined
·
653 Posts
I have the procedures for the grounding mod if you want it.
I agree it sounds like an wiring issue.
Mark
 
1 - 7 of 7 Posts
Top