Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 7 of 7 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
Ok. 2003 Speedmaster Carb. Fresh oil, fresh filter, new oil sensor and wiring. Anyone know how to get the oil light to turn off? I’m new to my Speedy
 

·
Premium Member
Joined
·
719 Posts
ChiefTree, hard to imagine you aren't building oil pressure after a simple oil change. Did you recently wash the bike? I had that trouble with my 2013 speedmaster after washing and discovered the boot covering the oil pressure sending unit had a tear in it and the water was grounding it out and making the light come on. I would give that a look.
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #3 ·
I’ll definitely look into that. I haven’t washed it recently and its new boot and sensor and all. I’ll definitely see if it’s being grounded though. It’s got plenty pressure. No spark though. Lol. I bought this bike from a guy that rode bikes his whole life but was scared of the thought of messing with an English bike. I got it from him pretty cheap and have been replacing/repairing/rebuilding on this thing since February.
 

·
Premium Member
Joined
·
719 Posts
Ok, I misuderstood and thought you had the bike running and couldn't get the oil light to go out. No spark at all? Could be pick up coil or igniter. Lots of threads discussing the trouble shooting aspects of both of those situations.
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #5 ·
Yeah. That’s why I’m just running down the the harness. New blue flame igniter, blue flame coils, ngk leads, ngk plugs, and new factory crank sensor. Also new relays. Just a fun game of hide and seek with this spark lol
 

·
Registered
Joined
·
2,033 Posts
Longshot, but did you happen to have the console on the gas tank apart and possibly mix up the "idiot lights" i.e. put the oil pressure lens on the neutral or high beam light?
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #7 ·
Longshot, but did you happen to have the console on the gas tank apart and possibly mix up the "idiot lights" i.e. put the oil pressure lens on the neutral or high beam light?
That was the first thing I checked. I have a new throttle assembly on the way. Once it arrives I’ll get back to figuring it all out
 
1 - 7 of 7 Posts
Top