Triumph Rat Motorcycle Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
164 Posts
Discussion Starter #1
Right turn signals work, but the gauge display does not.

Left turn signals do not work, but the gauge display lights up and flashes.

All turn signals have been replaced.

Any ideas before I just go and buy another flasher??

TIA.
 

·
Registered
Joined
·
10,211 Posts
My guess, based on your symptoms: Something in the left-side circuit is open.

The gauge light circuit is completed through the lamps on the opposite side (to the side that's flashing). So if your right side flashes, and your left side is open somewhere, the idiot light won't flash. The situation for your left side is just the opposite.

After checking the bulbs and sockets just to rule them out, I'd check all connectors in the left-side circuit, probably easier said than done. You'll need a wiring diagram. Since it's happening to both left lights, the break in the circuit is likely in the wiring that's common to both of them.
 

·
Registered
Joined
·
164 Posts
Discussion Starter #3
Thanks Marty. I did a cursory look at the wiring and fuses today. I installed the super mini lights (not LED) so it probably was my wiring job at the rear harness. Looking at those lights I don't think they're replaceable--certainly doesn't look like it, anyway.

Good info on how the gauge ckt is completed, thanks again.
 

·
Registered
Joined
·
164 Posts
Discussion Starter #4
Problem solved.

Mike at bellacorse told me that the lenses of the mini lights are replaceable and to lightly pry off the lenses. One of them was loose in its socket. Done.

I can't remember the last time something like this was so easily solved.....
 

·
Registered
Joined
·
10,211 Posts
It's always good when it turns out like that. :cool:
 
1 - 5 of 5 Posts
Top