Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 14 of 14 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter · #1 ·
Hi
I have a 1979 t140e with a stock Rita
ignition system. I don't like it and I don't
trust it. Can I replace it with a set of points?
Or if not, what would be a better system,
Pazon,tri-spark, etc.?
I am old fashioned, I like points.
Jeri
 

·
Registered
Joined
·
411 Posts
The only drawback with electronics are that most have to have a reasonable charged battery to work properly. The new Pazon from Sparxs keeps working at a lower voltage than most , so is the one to go for ( there may be others the guys will correct me). They are fit and forget though, but when they fail thats it. So grant you,you can carry a spare set of points and condenser with a points set up. But every time l have been stopped its been a battery failure, either flat or bad connection, not the electronic ignition. So you pays your money and take your choice!!.
 

·
Registered
Joined
·
5,847 Posts
well I reckon you can install points but you also gonna have to put in condensers and get a pair of 12 volt coils(yours are 6 volt). then you gonna have to futz with the wiring. would think it would be a lot easier (and cheaper) to leave as is until you have a problem. another idea is to sell your bike and buy a 78 or earlier T140 that came with points. I dont ever remember having any problems with FACTORY Lucas Rita system when these bikes were new.
jus my pinion
K

you any where near Bagnell Dam?
 

·
Registered
Joined
·
45 Posts
Hey Jeri,
I'm in SW Missouri (Nixa). Do you, or does anyone else out there know of a mechanic for a 72 t100r? I want to start work on my locked up basket case but I may need a hand before its all over.
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #6 ·
Hi Kadutz
I live near Clearwater Lake, thats in the southern
part of the state.
Anyway, my bike(t140e) is a great old bike.
I do not want to sell her!
I believe I am having Rita problems, wiring I think.
Usually starts with one or two kicks.
Then sometimes will not start at all.
If I had points I would have found my problem.
I am afraid to probe around on 30 year old
electronics too much.
My question I guess is, under the Rita relulater
is there a tapered spline that will accept a
Lucas auto-advance unit and would the timing
be like a 650 Bonneville?
Jeri
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #7 ·
Hi Doc Taco
I am putting together a 1972 T100r now.
It was a complete basket case.
My brother who is a very good bike mechanic
is helping me. We have learned lots about
the "C" range bikes the last few months.
So if you have questions maybe we can help?
Just shoot me a email anytime.
Also you know about Donnelsons in St.Louis?
They have been doing brit iron repair a very long time.
I also know a very good Triumph guy
that lives near Farmington, I will hook you up
if you need help.
Jeri
 

·
Registered
Joined
·
601 Posts
Hi
I have a 1979 t140e with a stock Rita
ignition system. I don't like it and I don't
trust it.
Jeri
To each his own Jeri, just remember when your
done scraping you Rita, to put the extra parts up
for sale because I like the Rita system.

Like I said to each his own,

Pookybear
 

·
Registered
Joined
·
1,123 Posts
Correct me if im wrong, but doesn't your bike have Negative ground?

What i can say is that your not the first one to request this swap over. At the Connecticut Brit-Jam last September one of the moderators was doing just such a conversion at the customers request, and no-one had ever heard of Tri-Spark for Twins EI.

My '78 has points right now, but it's also Positive ground.
Just a thought that might need more consideration?
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #10 ·
Hi Pookybear
Sell, well no, trade yes(for a points set-up)
Or if I would find somebody in need
I could just donate it.
Jeri
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #11 ·
Hi Morris
Yes, sir , negative ground, the first I have
seen on a old Triumph.
Yeah, I wish I could talk to somebody who
has done such a conversion.
You would not remember a name, of the
moderator I mean?
Thanks
Jeri
 

·
Registered
Joined
·
5,847 Posts
Jeri
Real purdy country down there. Used to ride to Lake Ozark every year . One day I got bored and rode to Mt home Ark and back just to relax. Wonder if the bikers still take over Lake Ozark on Memorial Day like they used to in the late 50's/early 60's...... Any ways I digress got a friend that has a '79 T140E. Bike would start and run ok most of the time sometimes would run then stop and not restart. Problem turned out to be a bad ignition switch. Now I'm not sayin that is your problem but it is a possibility. Also running problems have been traced to the kill switch.
K
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #13 ·
Hi Kadutz
The ride to Mt. Home is very nice.
I would never go down to the Lake on
Memorial Day, just too many damn people!
My Rita problem seems that at times I have
no spark at the left plug. Don't know if it is
the plug, wires, coils, or the Rita system and
its wiring. This is my first go-round at
trouble shooting a Rita system so I had to
do a little research(had no idea how it worked)
If it turns out to be the Rita I just may
replace it with a Pazon or etc.
Thanks
Jeri
 
1 - 14 of 14 Posts
Top