Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of September's Bike of the Month Challenge!
1 - 7 of 7 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter · #1 ·
I'm stranded far from home, TBird 2015.

Turn the key to run, no power to the instrument panel, no power to the ecu, headlights ok. This happened once before, but after an hour of flipping the key it finally powered up. At that time I took it to the dealer and they could not find anything wrong. I'm stuck, any suggestions?

Sent from my XT1064 using Tapatalk
 

·
Registered
Joined
·
1,196 Posts
That's a total bummer. Pull the main fuses, make sure there's no corrosion. Check em all.
Make sure the battery cables and grounds are TIGHT.
If possible pull the ignition switch and makes sure there are no loose connections. Make sure the ECU connector is push all the way in.

It does sound like a connection.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #4 ·
thanks, I'll check those again -- I've got an hour before the tow truck arrives.

Sent from my XT1064 using Tapatalk
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #5 · (Edited)
I wiggled all the wiring, reseated all the connectors I could reach, flipped the key back and forth, and after 2 hours, and 5 minutes before the tow truck arrived .... the ECM powered-up, the instrument panel came on, and the bike started. This is not as simple as the kill switch or kick stand switch since those do not effect the ECM power: I'm guessing it's the harness to the instrument panel, or the ECM, or that the instrument panel has an internal power problem: when the bike powered back up, pressing the turn signal switch would reset the instrument panel momentarily (all lights on, gas gauge scans up and down), but after 10 minutes or so that issue cleared. I rode home 150+ miles, but the bike felt like it would stall when I needed to stop at the lights.
Unfortunately, I doubt my dealer is going to know how to find this bug.


Sent from my XT1064 using Tapatalk
 

·
Registered
Joined
·
1,066 Posts
That sounds like a messed up ground to me.
 
1 - 7 of 7 Posts
Top