Triumph Rat Motorcycle Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Hi! I have a Triumph Thunderbird 900 2000 mod. So without further notice I suddenly started to get a "harder" sound. These engines have this well-known "whining/whistle", but now I think it's a kind of "thud-sound" I'm hearing through the whistling, or not thud-sound either, more a "harder" sound from the motor. This happened while idling also suddenly became higher. Must fix up the carburetors but wait for parts. But can I be in my head? Or is this signs of something wrong? Maybe I haven't noticed it before?
 

·
Registered
Joined
·
1,788 Posts
Don't take a Triple to Library.......

If you got no idiot lights, loss in power or compression, or real knocking, you are probably ok. These motors are naturally loud, many descriptions have been posted here to describe the sound.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
I really do hope you're right! And it comfoms me a lot what you say!

I think it wasn't there before, but I really don't know!

And, there is no other problems, no power loss etc, it runs like always! ?
 

·
Registered
Joined
·
19 Posts
Discussion Starter #4
Maybe the "thuddy" sound always has been there... I just tested it, really put a load on it in acceleration etc, and the bike runs like a charm all the way as before, just what I now start to think is me just noticed the "normal" sound from this motor. ??��???
 

·
Registered
Joined
·
70 Posts
Maybe the "thuddy" sound always has been there... I just tested it, really put a load on it in acceleration etc, and the bike runs like a charm all the way as before, just what I now start to think is me just noticed the "normal" sound from this motor. ??��???
Dont understand all the symbols?
 

·
Registered
Joined
·
19 Posts
Discussion Starter #6
When in "mobile wiew", you will see that the symbols are different kinds of "smileys".

When I now wiew in desktop mode, they appears like nonsense.

Another flaw with the mobile wiew, is that you can't reply with quotes, like I easily do here.
 

·
Premium Member
Joined
·
47 Posts
Maybe the "thuddy" sound always has been there... I just tested it, really put a load on it in acceleration etc, and the bike runs like a charm all the way as before, just what I now start to think is me just noticed the "normal" sound from this motor. ??��???

Did you recently add or change anything to do with wind protection? (flyscreen, windscreen, etc)

Maybe you are just hearing different sounds because of different air flow.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #8
No changes at all. I think this is just something that I haven't heard before, and just now noticed it.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #10
Look for something loose. If it's something heavy, like a "thud" it could be something like a mounting bolt. If it's less "solid" it could be a heat shield or something smaller (like the horn...)
Thank you! I will take a thorough look at it all.
 
1 - 10 of 10 Posts
Top