Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi everyone, new to the forum and new to triumph’s, I will also post this in the sprint section, I just recently purchased an 08 Sprint st that had been dumped, mainly cosmetic. It was sitting for about 2 years prior tho. So I took a few thinks apart, I got a new tank and a new fuel pump (old one was siezed), some new relays, new clutch and brake levers, new foot pegs, new battery, new cluster, new windshield, new rectifier and some other small things, so I put the fuel pump in and fuel and she won’t start. Cranks but no start. I don’t hear the fuel pump running, I believe all relays are good (not positive) I’m getting power to everything and the only engine code I have is for a faulty fuel level sender. If anyone can point me in the right direction I would appreciate it. Thanks in advance mike
 

·
Administrator
Joined
·
19,459 Posts
Welcome to the forum!

The Sprint forum is where you can connect with other Sprint riders. The folks there will best be able to assist you. Introduce yourself there, post photos of your ST, and join the banter.

http://www.triumphrat.net/sprint-forum/

Please complete your user profile so that we may see where you are from and what you ride as you post throughout the forums. Thanks!

http://www.triumphrat.net/profile.php?do=editprofile

Connect with local riders in the RAT forums. If you do not see a thread for your area, please start one.

http://www.triumphrat.net/rat/

You may also find local riders and local events in the Rides and Events forum.

http://www.triumphrat.net/rides-and-events/

Please share your home with us by posting photos of your rides in the Ride and Trip Reports forum.

http://www.triumphrat.net/ride-trip-reports/

Enjoy some off-topic and often humorous conversations in the Biker Hang Out forum.

http://www.triumphrat.net/biker-hang-out/

There is much to our forum, so please make yourself at home, browse the forums, and join the conversation where ever it may interest you.

Cheers!
 

·
Registered
Joined
·
49 Posts
Tip over sensor? Has been an issue on other bikes before...something that's overlooked but will prevent startup. Just a thought!
 
1 - 3 of 3 Posts
Top