Triumph Rat Motorcycle Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hello everyone,

Short story: 2008 Speedy, key on, no headlights, I hear and feel the click in the headlight/starter relay, no start. If I bridge the solenoid, it starts.

Long story: me and the mechanic are trying to solve this b*** of a problem for some time now, along with the classic Speedy electric issues. So we replaced regulator (mosfet upgrade), stator (moto electrical, good quality), battery, starter solenoid, starter relays (I have 3 new spares, swapped them and all!). We evem opened up the starter handlebar command and cleaned the goddamn contacts.
Also, fixed the severd headstock wire problem. Did the power upgrade mod with a kit from UK (for a Tiger, but it fits). I have been up and down the forums and I know the the theory about these electrical issues, but right now we just ran out of ideas...
I ordered a new handlebar command. I'll order a starter motor if needed. I'll order the whole damned bike, which turned into an expensive project :)))

Could it be the wiring? Should we open up the wiring guts and start checking inch by inch? Could it be the solenoid failing again?

All it does is click in the relay at the start and it starts if I short the solenoid.

Cheers!
 

·
Registered
Joined
·
900 Posts
Electrical issues are frustrating. Stating the obvious here but if the only remaining starting issue is solved by shorting the solenoid, I'd replace the solenoid, assuming you've checked that power is reaching the solenoid.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
The solenoid is brand new (or was). But I won't rule this out either. I am waiting for a feedback from the shop and then see what needs to be ordered. This has gone past frustration, I am really curious about what the issue could be.
 

·
Registered
Joined
·
900 Posts
Unsure if you mean the starter button by "ordered a new handlebar command" but I would stick a DVM on the solenoid to see if it is receiving the trigger signal from the starter button.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
I suspect that too. The starter button (which I ordered) on the handlebar has a double command. The one that goes to the relay works, because it clicks. Maybe the command to the solenoid is failing.
 
1 - 6 of 6 Posts
Top