Triumph Rat Motorcycle Forums banner

1 - 20 of 40 Posts

·
Registered
Joined
·
629 Posts
Discussion Starter #1
Now I just need to make a pipe that gets the muffler a little further away from the collector.

 

·
Registered
Joined
·
993 Posts
Whoa!! That looks clean as hell. :eek:

Stop skimping on the pictures man.

What silencer do you have lined up for it? That raw finish on the pipes looks sick, I'm considering stripping the paint off mine.
 

·
Registered
Joined
·
629 Posts
Discussion Starter #3
Wish my bike would start clean as hell :( I threw the pipes on and it cranked but wouldn't catch. Tank was low on fuel so I'm hoping moisture didn't get in there. I haven't ridden the bike for a while. Killed the battery trying to start it. I'm chagrin it right now so I'm crossing my fingers it's an easy fix
 

·
Registered
Joined
·
629 Posts
Discussion Starter #4
Well I used two different batteries and still wouldn't fire. Now to start the pain in the ass process of figuring out if it's getting fuel and spark :(.
 

·
Registered
Joined
·
1,810 Posts
Have you tried to start it without a silencer? If not there may not be enough back pressure for it to start...:)
 

·
Registered
Joined
·
629 Posts
Discussion Starter #6
Not the case at all! I started it with the header not welded together, with no silencer! Exhaust leaks all over the place, as free flowing as that system could possibly be lol. After it has been welded is when the starting issues arrived. Makes no sense.
 

·
Registered
Joined
·
3,282 Posts
Excellent!
I'm still looking for the same header to change my TBS as well.
There's a couple of 1050 headers, a 955, and a scratched 900 on ebay.de

Anyone know if the 1050 and/or 955 headers will fit?
 

·
Registered
Joined
·
629 Posts
Discussion Starter #11
Mine is from a 2003 speed triple, that help? I believe it is the 955i
 

·
Registered
Joined
·
629 Posts
Discussion Starter #12
But you have to cut off the ports and weld on the same style our bikes use like I did. Pain in the ass, and still not able to test it do to my bike not starting
 

·
Registered
Joined
·
629 Posts
Discussion Starter #13
Just a thought... Would welding the headers together while on the bike send enough voltage through the bike and fry something? Perhaps a battery? Haha... Haven't checked fuses yet. I had the clamp on the exhaust, so I don't think it would hurt the electrics on the bike. Just wondering though...

Thoughts?
 

·
Registered
Joined
·
3,282 Posts
Erm, yes they always say you should disconnect the battery before welding. Hope it hasn't damaged any other electronic parts, say a certain black box :eek:
 

·
Registered
Joined
·
629 Posts
Discussion Starter #15
That's why I'm taking a certain interest in a certain thread about that particular black box ;). I hope it's something stupid like a fuse or something :(
 

·
Registered
Joined
·
4,122 Posts
So you started the bike after you had the header tacked together, right?
The header was then welded off the bike, right?

And if you clamped the ground to the header when you tacked it together, you should be ok.
How's your kill switch?
I know I've done that before. Also trying to start in gear with the kickstand down will give me fits until I realize what I'm doing.
 

·
Registered
Joined
·
629 Posts
Discussion Starter #17
Fried battery, easy fix! Here's some pix!





 

·
Registered
Joined
·
629 Posts
Discussion Starter #18
Oh and yeah, she's a spit fire!

 

·
Registered
Joined
·
3,282 Posts
Cool as! Well done :thumb

Glad it was just your battery too.

Sadly the parts to do that are not easily (or cheaply) available over here, the best I found was a set off a Speed Triple with a big dent in one pipe for €45.
 

·
Registered
Joined
·
4,122 Posts
Cool as! Well done :thumb

Glad it was just your battery too.

Sadly the parts to do that are not easily (or cheaply) available over here, the best I found was a set off a Speed Triple with a big dent in one pipe for €45.
Fill it with water and freeze it. Icing it up a few times might force the dent out.
 
1 - 20 of 40 Posts
Top