Triumph Rat Motorcycle Forums banner

1 - 12 of 12 Posts

·
Premium Member
Joined
·
380 Posts
Discussion Starter #1
Right, I've had my speed triple for about 9 years or so and today was the first time she let me down. I should be on a ferry to France right now with my mates but hey ho..... I found this great resource for trumpet knowledge! So fellas, can you help me figure out what the issue might be!?

The symptom goes something like this..... just came onto the motorway, cruising at about 80mph for 2 miles and I felt a slight wobble and the engine cut out! All the electrics stayed on but the revs just dropped away! I cruised to the side of the road and although she was turning over she wouldn't fire up again. So I phone the recovery truck and waited around like a lemon for 45minutes, told the fella the story and went to show him the bike turning but not firing and low and behold she started!!!!!! The fella looks at me like I'm a right knob and suggests I ride on while he follows. Thankfully (if only for my self respect) she cuts out again! This time the bike is loaded up and I don't look so stupid!! :)

So guys, short of taking my bike to the main dealers I'm kinda stuck.

Have you got any suggestions!? :(
 

·
Premium Member
Joined
·
3,646 Posts
yup, classic pickup coil symptoms
 

·
Premium Member
Joined
·
487 Posts
It if doesn't go away when you switch the petcock to prime, my guess is it's the pickup coil (ignition sensor) pn T1290022.
 

·
Premium Member
Joined
·
3,671 Posts
Alright Silkie,

S**** timing for it to let you down..! does sound like pick up coil though, when hot it misbehaves, let it cool a little and it works again, easy enough to get to behind the R/H side timing cover, the only place you'll get one today is a breaker (All Bike Engineering in Greenwich might be worth a go) who knows, you might be able to fit one and play catch up with your mates, I would order a new one long term though.

Good luck either way

Mot

Oh and I could be wrong ? but I think most of the early T3 bike ones would do, Trophy Daytona etc etc
 

·
Registered
Joined
·
826 Posts
yup, defo a pickup coil!
any t3 model should fit
fingers crossed you get it sorted, and are able to catch up on your trip!
 

·
Premium Member
Joined
·
380 Posts
Discussion Starter #7
Cheers fellas

I found a pickup coil about 1hr 10mins from my place. Leaving in a bit to grab it..... I wont be able to catch up with my mates but spending the afternoon tinkering with the old girl is hardly wasted time. This might be a quick job for some of you guys but I'm a total noob when it comes to getting my hands dirty and this could take (me) a while so don't wanna stress about time ticking along, slowly slowly catchy monkey and all that!! I'd rather take my time and get it done right.

I'll keep you guys posted as to how I get on.

Cheers all!!

Off to Washington............!!!!!!!!!!!!
 

·
Registered
Joined
·
1,655 Posts
if its not too late....... also get a gasket for the cover, and a bit if silicone sealer to go round the grommet on the cable exit.
 

·
Premium Member
Joined
·
380 Posts
Discussion Starter #9
Sorted! I hope!!!

So fellas, The new pickup coil is in and it starts!

I guess that's as good a test as any. Haven't been able to go out on her and test any distance as I have all the body work of and all the mounts for the plastics where perished so have ordered them up and I should get them Thrusday/Friday next week so can put her back together then and give it a proper run (With the breakdown truck at hand!).

Thanks for your help gents. A main dealer visit could have been turned into a £35 pound part and a couple of hours in the garage.

After reading the comment about the petcock I have noticed it seems to be leaking a touch. Nothing drastic but enough to make the tap glisten and moist to the touch. Should this be dry as a bone?

Lesson one on T3 self maintenance is a win! :D
 
1 - 12 of 12 Posts
Top