Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of October's Bike of the Month Challenge!
1 - 3 of 3 Posts

·
Registered
Joined
·
3,077 Posts
Discussion Starter · #1 ·
The other day I discoved the hose that comes out of the crankcase had blown out. I put it back in, but it came out again.

Is there something missing in these pictures?

I plugged it back in, and secured it with JB Weld. Durring the next ride, it blew out again breaking the JB Weld.

I checked the hose and it isn't plugged. Does this mean there's something wrong with the airbox?

Also, if I switch to pod filters, what do I do with the breather hose?

Kem
 

Attachments

·
Registered
Joined
·
792 Posts
well not sure on this but if the hose is blowing off all the time ,id be checking to make sure its not kinked or blocked in some way,you dont say if it has broken of were it goes into the crankcase or not,but id say with the presure in there if its broken off you need to replace hope this helps
 

·
Premium Member
Joined
·
1,104 Posts
Looks just the same as mine, so I would say from your photos that there's nothing obviously missing. It suggests to me that the hose is blocked somewhere between the crankcase and the airbox, although from what you write it reads as if the actual hose union has broken off? Could just be that under pressure the hose clip proved stronger than the metal union.

In answer to your last question, have a look at this thread, in particular the last two posts and post #21:

http://www.triumphrat.net/hinckley-classic-triples/85233-pod-mod.html

Also this thread:

http://www.triumphrat.net/hinckley-classic-triples/149539-crankcase-breather.html

and most recently, this one:

http://www.triumphrat.net/hinckley-classic-triples/156704-airfilter-pods-behind-side-panels.html
 
1 - 3 of 3 Posts
Top