Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 6 of 6 Posts

·
Registered
'05 Sprint ST
Joined
·
187 Posts
Discussion Starter #1 (Edited)
As title, at random the bike acts like it's battery is dead but let off the starter button, give it a moment and it starts normally... I hate electrical faults. It usually happens when the bike is warmed up.
I have had a search but couldn't find an answer to this intermittent problem.

The bike is a 2005 1050 with 22k miles.
 

·
Registered
Joined
·
3,804 Posts
I don't know if this is it but replacing the battery leads with something a bit stouter perked up Sir Costalot.
 

·
Registered
'05 Sprint ST
Joined
·
187 Posts
Discussion Starter #4
I have a set of "Pudding Cables" to go on when it get's it's full service and might put another battery on if those don't help, I can see how the Sprint can be hard on batteries as there's no delay on the headlights, 2x55w bulbs on while it's trying to start seems unnecessary.

The cables are beefy (50mm²) and under £25 delivered.
 

·
Registered
Joined
·
16 Posts
Headlights should cut out when starting,if they are staying on you could look at chucking a new starter circut relay in.Kim
 

·
Registered
'05 Sprint ST
Joined
·
187 Posts
Discussion Starter #6 (Edited)
I will have another check to see if the headlights do go out, I know they dim but will make sure... It's a good job I love this bike lol it's certainly got a character.

EDIT
Yes they do turn off when cranking, that's one thing that's not causing the fault:)
 
1 - 6 of 6 Posts
Top