Triumph Rat Motorcycle Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
:mad: hey guys how ya doin ?
so i just installed a pazon sure fire EI. i wired everything up just like the book says. i set the static timing using a degree wheel on the cam. the book said if using a degree disc attached to the cam the full advance figure reading must be halved.so my degree disc was set to 19 degrees. i took the plugs out and they where wet. i cleaned them and kicked it over to check for spark.there was spark. still wont start.
befor i put the ignition in i changed the oil, and put a can of lucas carb cleaner stuff in the tank. i
think thats about when it wouldnt start.
now on my light panel the amber light on the left goes out after i kick it.it takes a 2 or 3 seconds to come back on. sometimes it takes forever to come on. could that have anything to do with the kill switch on the right bar ? i pulled it apart to see what was leaking out and the switch was ful of rusty brake fluid. yes my master is leaking. could that leaking fluid screw up the kill switch.
back to the top it had spark.
*** :confused:
 

·
Super Moderator
Joined
·
12,494 Posts
Check your right/left cylinder connections if applicable on the Pazon (never set one up); also the two trigger leads could be swapped if it's like the Sparx & Boyer.

The light thats going on and off is the oil pressure light, perfectly normal. You want it on when the bike is not running, and off when it is!

I don't like liquid carb cleaners in the fuel, personally.
 
1 - 2 of 2 Posts
Top