Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of October's Bike of the Month Challenge!
1 - 4 of 4 Posts

·
Registered
Joined
·
88 Posts
Discussion Starter · #1 ·
I went to start the beast and I get zero juice when I turn it on. I had this problem before and with a little jiggle of the key she came to life but now it looks like it's permanent. Anyone change out their ignition switch? I could not find anything in the manual on it. I know it has two tamper proof screws that will have get off. Can anyone help?

Thanks
 

·
Registered
Joined
·
896 Posts
I have had no problem with the ignition key in 60,000km but occasionally it will not respond to the starter button. I suspect that my problem could be related to the clutch lock out switch at the clutch lever. If it gets worse, I will disconect the switch and join the wires. davo
 

·
Registered
Joined
·
237 Posts
You might try flooding the key hole with WD-40, getting the straw down into the switch assembly as far as possible, then working the key on and off. It could be you have some corrosion in the contacts. Bigern
 
G

·
Mine did the same thing yesterday. I removed it and appears to be internal in the switch itself. My dealer is ordering me a new one this next week.
Only trick was the break away screws. I took a small chisel and broke them loose, then took a small screw driver and worked them out.
I won't put them back. I'll use regular screws.
Oh, and it won't do any good to squirt anything into the key hole. The switch is below the lock cylinder and there is no way you can get anything into it by squirting into the lock.

[ This message was edited by: Rocket_Rider on 2007-02-24 21:15 ]
 
1 - 4 of 4 Posts
Top