Triumph Rat Motorcycle Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
409 Posts
Discussion Starter #1
Need your thoughts please.
Late 06 ST

Bike stutters and spluts at all revs sometimes.
If at lights I lean it to the side it runs normally.
If I am on a hill it runs normally, sometimes.

I run about 100 miles a day and it has been stuttering for three of these, is it trapped water or?

Advice for this weekend to solve it would be beneficial.
Previous threads discuss cleaning plugs and possible water, is this a easy thing to do. Others discuss 'coils', what are these in this relation...
Cheers in expectation
Jim
 

·
Registered
Joined
·
113 Posts
If at lights I lean it to the side it runs normally.
If I am on a hill it runs normally, sometimes.
Those seem to me to be the key indicia. Could there be something blocking the fuel pump intake such that leaning it lets the fuel in? I would be surprised if there were a loose electrical connection that fully connected when you leaned it to the side. Couldn't hurt to check all the electrical connections.
 

·
Premium Member
Joined
·
3,030 Posts
Water in spark plug wells.

Or fuel tank breather blocked (by crud or stuck tipover valve) if the starvation / weak running happens on high revs too.
 

·
Registered
Joined
·
213 Posts
I had this problem, the bike would stutter sometimes then pick up and run fine. The breather hose was blocked and when i washed the bike, water would gather just inside the filler cap. Under braking the water would surge forward and enter the tank contaminating the fuel. Cleaned the hose out and its ok now.
 
1 - 4 of 4 Posts
Top