Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
88 Posts
Discussion Starter · #1 ·
My MIL (Malfunction Indicator Lamp - the yellow one with the motor symbol) has started to glow with a steady light). Temp and oil etc + engine performance ok. Restarts and runs perfectly fine but the lamp is on. I just had the 6000 mile service done on this -08 model. I have no Tuneboy so I'll have to wait 3 days (over the weekend) to get the ECM codes read at my dealer (an hour one-way drive from here).
Since I have the BIG D675 manual it says: "When a fault has been rectified the MIL will remain illuminated until sufficient non-fault warm-up cycles have taken place to turn it off".
So question is: could it be an idea to do a couple of warm-up cycles to see if it was just a "****-error" that cured itself? Or are we talking 50-60 cycles? Any ideas?
 

·
Premium Member
Joined
·
1,732 Posts
Depends on the error code that was initially thrown. Many codes will clear after only 3 cycles. Some will not clear and must be reset.
 

·
Registered
Joined
·
88 Posts
Discussion Starter · #4 ·
MIL ok

MIL went ok after no more than 3 cycles. The tip was big help since it was a bad time to go to my dealer today. Now I can check any stored DTC at will.
You see, the MIL went on after I was taking a serious wiper-fluid shower from a bus in front of me. Any sensor went nuts from that??
In any case a TuneBoy would come in handy. How much goodies can Santa carry? - tyrewarmers, TuneBoy, Speedshift, flushmount blinkers, dual-headlight...
 

·
Premium Member
Joined
·
1,732 Posts
Glad you were able to get it sorted...
 
1 - 5 of 5 Posts
Top