Triumph Rat Motorcycle Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello,

I'm a 1200XRx rider and have a problem. This is my second Tiger 1200 but never need this information until today.

I tried to adjust my handlebar but after completed my left controls stopped working. Horn, clutch lever check, buttons don't working after adjustment. I guess that a socket unplugged (I hope) how can I reach that socket to check? Any ideas or experience about this?

Thank you
 

·
Registered
Joined
·
81 Posts
Hi, I think you may be lucky and not need to go under the tank, I had similar problems (both sides) when I fitted risers to mine. The wiring connects into the switch cubes with a micro connector, I'd put a bit too much strain on the cables and they'd just eased out enough so that one side wasn't working at all and the the other was intermittent. Just push the small connector in the direction of the arrow and make sure it's fully home (same both sides).
733579
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Hi, I think you may be lucky and not need to go under the tank, I had similar problems (both sides) when I fitted risers to mine. The wiring connects into the switch cubes with a micro connector, I'd put a bit too much strain on the cables and they'd just eased out enough so that one side wasn't working at all and the the other was intermittent. Just push the small connector in the direction of the arrow and make sure it's fully home (same both sides).
View attachment 733579

Thank you I'll check and share the result with you
 
1 - 4 of 4 Posts
Top