Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 10 of 10 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 · (Edited)
I seem to be having a hot starting problem. It seems to be getting worse as time goes on. Motor warm or cold no problem. But an immediate restart after fueling is near impossible. Bike was running good before. Changed to smaller pilots, but didn't help. Push starting works though. I was told i may have a sticking valve...any thoughts. Plan on tearing into it more tomorrow. Runs great once it's started and dosent hesiate...08 thruxton 6,000 miles, no dealer close.... Starter turns engine over and dosent hesitate, just dosent fire.
 

·
Lifetime Premium
Joined
·
1,670 Posts
^^ Yea, if it's not cranking, it's likely electrical.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
Yes, as i stated it turns over just fine. Rode it to work this morning. 20 miles just fine. Turned it off...wouldn't restart. I believe it is a bad pick up coil like davidc said....
 

·
Registered
Joined
·
210 Posts
I'm starting to notice that every now and then on my 08 also...believe the pick up coil is the culprit
 

·
Premium Member
Joined
·
20,740 Posts
There's a service bulletin released by Triumph some time ago that asks for the pick-up coil gap to be reduced to 0.8 mm from what the service manual states, that is 1.00 mm+-0.2.

It might be for that reason.
 

·
Banned
Joined
·
9,598 Posts
Funny cuz i had the same issue PLUS stalling for no reason at idle occasionally both when warm on my 05 speedmaster, and RAISING the pilots stopped that issue completely.Not saying it'll work for you, but it did for me. Tho i had modded airbox and pipes.
 
1 - 10 of 10 Posts
Top