Triumph Rat Motorcycle Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter #1
Went out on my Trophy (1999, 900) today for a short run. After a while the bike died on me. Pulled to the side of the road and hit the starter....nothing. Kept trying and after about 5 mins it fired into life. Left it running for a few mins, then got back on and set off. After a few feet it hesitated and died again. Kept trying to start it........nothing. Ended up with fuel running out of the air box. After a few mins it started again but would not run when the throttle was opened wide. At that point l gave up and got a lift home.

Anyone got any ideas please!
 

·
Registered
Joined
·
35 Posts
Hi Shep

Sounds to me like the pick up coil (right hand side of the engine under the round cover) easy job to change mine went on the Severn bridge in the fast lane the every mile or so until it would only run for a few minutes, i was convinced that it was wet electrics or a broken wire coz it kept starting after I played with the wireing. but still cut out again. Im sure your bike will start staight away tomorow but it will soon cut out again when it gets warm. cost me about £65 for the parts.

hope this helps Griff
 

·
Registered
Joined
·
83 Posts
Discussion Starter #3
Hi Griff

Think you could be right as l am sure its an electrical problem as it stopped dead, not stuttering as if it was running out of fuel, and when l did get it going for a short while it was missing and backfiring as if the ignition timing was out. I'm sure the fuel running out of the air box was just the way it was parked and the engine flooding as it would not start.

I'll check that out. Thanks for your help

Steve
 
1 - 3 of 3 Posts
Top