Triumph Rat Motorcycle Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
hey all...

so i've had my '96 tiger (10k miles) less than a month now and it's developed an electrical issue in the last two rides:

with ignition "on" all power, except to the turn signals, is completely off. it started as an intermittent problem at low idle and would go on and off while at stoplights or coasting, but this afternoon on my way home from work it started cutting out on me completely while riding 40mph down the street. by the time i got home it was completely shut down and at this point the only thing that has power are the turn signals! i've fidgeted with all the obvious wires, ignition pod and battery, but have not delved any deeper before i came here looking for advice. and any of the sort would be greatly appreciated!

thanks, darin
 

·
Registered
Joined
·
922 Posts
I havent got a wiring diagram for the steamer but if it is the same as the Girly I think the side lights and turn signals are powered from a different set of contacts in the ignition switch ( so you can have the hazard lights and park lights on with the switch in the locked position) so if they are OK then you might have a problem with the insides of the switch.

the clock OK?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
i woke up this morning with the same thought. and yes, the clock is still working. i assume it's wired to it's own circuit.

is it safe to assume that the whole ignition assembly might have to be replaced?

and can i ask if there is any other source for oem parts other than the triumph dealer or bikebandit? are there any salvage parts available for these things?

thanks again!
 

·
Registered
Joined
·
724 Posts
Mine died on me a while back, though I had lights and everything else it just wouldnt start. Turned out to be a cable connection on the clutch lever, the cable was snapped inside the heat shrink.
Try the link below(if it works) if you cant get any help here before you start splashing out on bits you might`nt need.

http://www.webbikeworld.com/triumph-tiger/
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
starter solenoid?

so i realize that i've posted in the wrong area of the tiger forum...all apologies...and i will expect this thread to be moved but in the mean time...

i still have no power to anywhere on my bike but the turn signals. i've been checking wires all day and finally busted out the test light. i have power going to the starter solenoid but none coming out...would this correspond to the previously mentioned symptoms and if so would indicate i have a bad starter solenoid? would a bad solenoid prevent all other power to the headlights, horn, dash lights and all from coming on? can anyone help?
 

·
Registered
Joined
·
724 Posts
Might help?

To look at a post by sofalofa about a `starter motor 2005` my woes started on page 2 and theres a photo on page 3 or 4 of the offending item. Its all in the write up:)
 
1 - 6 of 6 Posts
Top