Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
1999 Sprint ST 955i
Issue: Headlights not working as expected. The following is my the steps and the results.
  • Ignition switch to on. Lights switch to on.
Left headlight working. Right off.
  • Switch to high beam.
Right headlight switches on. Left headlight switches off.
  • Switch High beam off and push “Pass” switch.
  • Left headlight is on, stays unchanged. Right headlight comes on.
 

·
Registered
Joined
·
484 Posts
Ok, I assume you've checked the bulbs? Swapped them over too? Do they share the same fuses?

What's normal behaviour for 955 headlights? Both on for low and high beams?
 

·
Super Moderator
Joined
·
3,300 Posts
Someone correct me if I'm wrong, but didn't pre-2001 955i Sprints have some interesting lighting set up, and you could get a dual-relay set up so that both lights would turn on for both dipped and main beam use? I was trying to search it, but was having no luck just now finding that tidbit.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #6 ·
Someone correct me if I'm wrong, but didn't pre-2001 955i Sprints have some interesting lighting set up, and you could get a dual-relay set up so that both lights would turn on for both dipped and main beam use? I was trying to search it, but was having no luck just now finding that tidbit.
Interesting. That would be good to know, might be working to spec then.
 

·
Registered
Joined
·
2,322 Posts
Yes. At least in France the bike was delivered that way. You may add two plain automotive 12V relays as stated above in the empty sockets.
@DEcosse: I thought In California those two extra relays were stock.
 
1 - 9 of 9 Posts
Top