Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Gents--

Having issues with the headlights on my '01 ST--both should be on at all times (i don't have the switch on the handlebars).. Only the right side is on in LOW, and when i turn on the HI's, the left comes on and the right goes off !! Both bulbs are new and good. Fuses are in tact and working. I have removed the front and gained access to the relays. I have removed the relays, checked for junk or damage and replaced (even swapped them around and have had no changes). Wondering if i can get this type of relay at any auto parts store, or if it is something i have to order online? Anyone else ever have this issue? I have the manual and the wiring diagram, but it is just lines and colors to me...

any help is greatly appreciated.
 

·
Registered
Joined
·
219 Posts
http://www.triumphnet.com/st/faq/elec/

Q: Only my right headlight is used for dipped beam, and the left one for main (high) beam. Can the lights be rewired so that both work on dipped and both are used for hi-beam? ?

A: Yes. On 99 STs, you will need to order the set of two by-pass leads, which consist of a white plastic connector block and twin black shorting leads. These plug into the respective connectors coming from each headlamp unit, under the left and right sides of the upper fairing, just next to each headlamp unit (access from the space between handlebars and the dash). These cost about DM12,- (6 euros)

* On 2000+ STs, you will need to fit two relays, part number T2500234.
* On the RS model, you will need two relays, part number T2500233
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
Need help with headlights and/or relays!!

Gents...

i've been struggling with a headlight issue that seems very odd..i ride an '01 Sprint (red, of course) and only the right side light comes on in LOW...when i switch over to HI, the right goes out and the left comes on!! I've changed out both lamps with known good ones, i've checked all the fuses--i now have the nose off and have removed, cleaned, and swapped around the relays....with no success. I have my manual, and the wiring diagram, but they are all just lines and colors to me...

Question #1 is--has anyone else ever seen this problem? if so...please send advice

question #2 is--is the relay a standard piece that i can find at any auto parts store?

question #3 is--are there other relays/dip switches/components i should check that i haven't yet?

you're help is greatly appreciated....would rather have it under me than in pieces in the garage!!

thanks!!
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
empty socket?? on the relay bank? there's only 4 ports, and all are populated...one goofy thing i see is a dangling connector going nowhere off of the LEFT headlight cable...is that what you're talking about???

You just need to add the relays to the empty sockets.

Et Voila! :p

This is designed like this for some markets - the one socket is left unpopulated to actually make it operate as you describe.
 
1 - 5 of 5 Posts
Top