Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I'm on a new 2008 Tiger with less than 2K miles so far and loving everything about it EXCEPT the headlights are dead! When the first one went I grumbled and replaced the H7 halogen bulb on the left, disconnecting the battery as instructed in the manual. That seemed to do the trick, but it went out on the very next ride. Getting paranoid now, I used the high beam for the right lamp on the way home, but by the time I made it (less than 30 minutes), that one was out too. The (useless) little light above the main headlamps are working fine, by the way, as are all the other indicators, horn and electrics. It's a warranty fix, but my dealer is 50 miles away and I hate to drop it off for days for something simple. Any bright ideas? A bad/overheating relay maybe? Grrrrrr.

Thanks in advance for the help.
 

·
Registered
Joined
·
72 Posts
I'm on a new 2008 Tiger with less than 2K miles so far and loving everything about it EXCEPT the headlights are dead! When the first one went I grumbled and replaced the H7 halogen bulb on the left, disconnecting the battery as instructed in the manual. That seemed to do the trick, but it went out on the very next ride. Getting paranoid now, I used the high beam for the right lamp on the way home, but by the time I made it (less than 30 minutes), that one was out too. The (useless) little light above the main headlamps are working fine, by the way, as are all the other indicators, horn and electrics. It's a warranty fix, but my dealer is 50 miles away and I hate to drop it off for days for something simple. Any bright ideas? A bad/overheating relay maybe? Grrrrrr.

Thanks in advance for the help.
Yours is the 1st I've heard of this happening to. Plenty of gripping about the lack of brightness of the low or dip beam and also having to re-adjust the height setting from the factory. A lot of the new Tiger owners on http://www.tiger1050.com have replaced theirs with HID systems. You definitely have an electrical warranty problem and might as well resign yourself to taking it back to your dealer!

Good luck
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Afraid you're right, Hog -- the ugly truth rears its head and I've exhausted the limits of my trouble-shooting ability (at least without risking making the problem worse - my specialty!). Hoping to get the bike into the shop today - will post the outcome here in case some other poor sucker with a new Tiger hits the same snag.
 

·
Registered
Joined
·
1 Posts
Bulbs and finger oil

I know I do not need to say this, but I feel compelled to. I have seen halogen bulbs explode on the inside from touching the outside part of the bulb. The bulbs when lit get really hot. Somehow human finger oil when left on the glass magnifies the heat and they have premature explosion. I always clean new bulbs, if I touched them or not, with cotton balls and rubbing alcohol.
 
1 - 4 of 4 Posts
Top