Triumph Rat Motorcycle Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hello!
I recently installed one of those cheap eBay led lights on my 14’ Bonneville. The light is working fine but I can’t get the halo ring to turn on at all

The light has a H4 connector and there is another connector that v’s from that same line, which I assume is the connector that lights up the halo. There is also a separate adaptor that I know nothing of that came with the kit.

I’ve attached a few pictures for reference.

Do any of you know how to get this halo to light up or had any of the same issues? Thanks!
 

Attachments

·
Premium Member
Joined
·
928 Posts
Hello!
I recently installed one of those cheap eBay led lights on my 14’ Bonneville. The light is working fine but I can’t get the halo ring to turn on at all

The light has a H4 connector and there is another connector that v’s from that same line, which I assume is the connector that lights up the halo. There is also a separate adaptor that I know nothing of that came with the kit.

I’ve attached a few pictures for reference.

Do any of you know how to get this halo to light up or had any of the same issues? Thanks!
On my bonneville there was a smaller plug inside the bucket that I think was/is for daytime running lights and I had to if I remember right, I had to splice to a smaller tail on the headlight, I know thats not a very good description of how to but I know the halo needs an auxiliary power source, I was able to call the light manufacturer/distributor and got some assistance.
 
1 - 3 of 3 Posts
Top